Extremely bad low end torque - WOT to get moving

Just fired up my Kinetic TFR to take it for a spin for the first time today (was non running before, fixed it with a new carb and filter right before Winter hit and had to put it in storage)

I've heard TFRs don't have much torque, but I'm thinking something isn't right because it basically needs full throttle and help pushing off to even start moving. Once it gets going I basically have to keep it full throttle the whole time.

It seems to run pretty smoky too - the fuel cap said 3% oil mixture so that's what I put in it, but I'm thinking that's too rich. Could this be contributing to the problem?

For what it's worth this is the carb and filter combo I put in it:

https://www.treatland.tv/MALOSSI-dellorto-SHA-13-13-carburetor-and-filter-p/malossi-sha-13mm-kit-1610866.htm

Re: Extremely bad low end torque - WOT to get moving

What jet did you put in the carb when you installed it?

Re: Extremely bad low end torque - WOT to get moving

Jessie Paull /

Came with a 65 jet installed so I left that in. I also picked up a 59 and 62

Re: Extremely bad low end torque - WOT to get moving

I’m a Vespa guy, not Kinetic. But I’m guessing the bike came with a 12.12 carb, probably with a 46-49 jet. You’re probably way too rich. But again, just guessing from Vespa specs, since kinetic is Vespa clone.

What size carb was on it before you changed it?

Re: Extremely bad low end torque - WOT to get moving

Jessie Paull /

Very close - original carb was a 12.10 with 45 jet. My understanding is that with a bigger carb and performance air filter I should be upjetted from stock, but maybe 65 is too far. Any idea what size would be more appropriate? I can swap for the 59 jet I have, but maybe I'll pick up a few more sizes just to be safe. (edited)

Re: Extremely bad low end torque - WOT to get moving

to be safe clean n put og carb on. every setup is different, or downjet the new carb.

Re: Extremely bad low end torque - WOT to get moving

Dirty30 Dillon /

Yeah, 65 is way too rich for a stock Kinetic. 59 is probably still on the rich side, but would probably run much better

Re: Extremely bad low end torque - WOT to get moving

🇮🇹💦 Of the Loin /

54 is about right

Re: Extremely bad low end torque - WOT to get moving

Yep, just as I thought. You’re way too rich. If it had 12.10, with 45 jet stock, then with the bigger carb, and hi flow filter, I’d guess you should be low-mid 50’s with stock exhaust. Put a performance pipe on, like a circuit pipe, and you’ll be high 50’s-low 60’s, with waaaay better low end torque and acceleration.

Re: Extremely bad low end torque - WOT to get moving

Jessie Paull /

Good deal - thanks for pointing me in the right direction guys. I'll swap jets and report back

Re: Extremely bad low end torque - WOT to get moving

Jessie Paull /

Just an update: running rich was definitely the problem. I brought the jet down to 55 and its waaay better. Acceleration is still a little slow at first, but it gets up to around 33 pretty easily. Next step will be a proma pipe to get more speed and hopefully acceleration.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account