I got the blues but I'm slipping to much!

Put the blue springs on my morini m1 cutch...polini/vm 18/techno estoril/ sebring

Springs are to stiff....slipping to much on the bottom end and I can't find any other springs that will engage a little sooner...blues are 5 k I think...2.5 k would be better.

Maybe I should go Back to stock springs and lighten up the shoes instead

Any info on either direction would be much appreciated...did some searching and came up with a lot of short threads with no solid answers :)

Stock springs are 10mm x 37.5mm

Re: I got the blues but I'm slipping to much!

Hmm, I ran much beefier springs in a similar setup. Are you running ND30? You might find ATF to slip slightly less.

Re: I got the blues but I'm slipping to much!

Yeah I'm running the ND30...I read that thread you posted a few years ago and got the link for those springs. How did they work out for you?

Re: I got the blues but I'm slipping to much!

whats your gearing?

Re: I got the blues but I'm slipping to much!

Dan Ott Wrote:

-------------------------------------------------------

> Yeah I'm running the ND30...I read that thread you

> posted a few years ago and got the link for those

> springs. How did they work out for you?

They were great in AZ but terrible anywhere in Seattle. I ended up switching to red derbi springs.

Re: I got the blues but I'm slipping to much!

greg waldo Wrote:

-------------------------------------------------------

> whats your gearing?

13x34 and I'm topping out at 53 mph (9400 rpm)

Just trying to get some quicker acceleration on the low...I'm hitting the pipes powerband on the bottom but clutch needs to grab a little sooner...I'm just slipping to 5k...pipe can handle grabbing at 3k and the polinis got the lungs for it :)

I'm changing the gearing when I get back from Montana....rear sprocket

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account