hobbit problem

Derick Soland /

my parma kit with 21mm delossi carb hobbit runs great and has for months, i was riding it going about 40mph and it all of a sudden bogged out then stopped running now it will only start with the choke on and it will rev-out and if i turn the choke off it will just shut down, need help thanks.

Re: hobbit problem

Take the kit off and inspect cylinder, piston and reeds.

If oK, then put new gaskets on and heat cycle it before you rip it again.

Re: hobbit problem

don't do what he said yet. Maybe you have poor fuel flow. Hows your tank? If it's rusty at all. Check your petcock screens.

check fuel flow by removing the hose and pointing it to a container and turning it to On and Reserve and observe the flow it should be a steady flow as thick as the inner fuel line. Or your carbie is plugged.

Delossi hah

Re: hobbit problem

yeah, fuel flow first, then open..

Airleaky?

Re: hobbit problem

Derick Soland /

well, the fuel flow is great, i put a new main jet (92) in it and everything seems to be fine in the carb, i took the head and kit off and everything looks great, put it all back together, it still starts in choke and revs to the limit and dies when the choke is off, stuck im out of ideas need help thanks.

Re: hobbit problem

Air leak, or clogged something...

Have you changed your seals?

Re: hobbit problem

Derick Soland /

checked the compression and its good, and fuel is good so im guessing i have a leak somewhere after my carb but everything looks good i can't find it. Could it possibly leak inside the lower part of the engine?

Re: hobbit problem

JBOT ... Wrote:

-------------------------------------------------------

> Have you changed your seals?

Re: hobbit problem

[Radium City] kyle k $ /

mechanic: looks like u blew a seal

penguin: no, it's just ice cream...

Re: hobbit problem

Silly question but have you tried just replacing the plug? Fowled plugs will sometimes still run with the choke on.

Re: hobbit problem

Derick Soland /

well the head and kit seals both looked good, I'll buy them just seems weird to me if i have good compression and they look fine why they would be bad. Are there any other seals that can go bad? already tried spark plug (edited)

Re: hobbit problem

Do you got any oil weeping under the flywheel or maybe even the vario? do you have a propane torch? You can use propane to test for airleaks on crank seals. Rev the motor and let off with a torch on top of the flywheel or vario on full blast.

Dunno - its what i'm doing on my hobbit. Crank seals.

Check your points too - maybe you have a bad condensor/points setup?~!2321e2314seafeSaffads

Re: hobbit problem

Derick Soland /

doesnt leak oil anywher, really believe it is an air leak somewhere due to it starting in choke and reving out.

Re: hobbit problem

Maybe try some starter fluid/carbcleaner/soapywater/propane while the motor is running around mating surfaces. That may narrow it down for you! If you think you know what it is - thats good! Your probably right.

Intake airleak? have you cleaned the carburetor recently? leaking around the reedblock?

Check between the carburetor + airbox, carb intake setup and reed + intake on the motor.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account