I don't get it....

Ok so I have an e50 maxi with a dellorto 21mm, malossi filter, 70cc treats w/ hi head, boss pipe. I had her runnin nice until my fuel bowl cracked and caused a major air/ gas leak. I fixed that, but it's still boggin real bad, even back firing on me. (when on the kickstand) if i go from not touching the throttle and then suddenly give it WOT it wont rev up at all, but if i SLOWLY open the throttle it'll scream to high rpms like it should. I have an 82 jet in it right now but it's about 45 degrees Fahrenheit where i am so maybe mother nature is fuckin me up??

Re: I don't get it....

Like “Funkenet” Hosfield /

How's your timing?

Re: I don't get it....

I haven't ever messed with the timing since buying it

Re: I don't get it....

Like “Funkenet” Hosfield /

So you are trusting either whoever had the moped before you or 30+ years old factory settings with your expensive(ish) performance parts?

Time to learn how to set your timing.

The wiki and the manual is a good place to start.

Either there is water in your fuel or its the timing. I would start with timing, its a good thing to know how to do.

Re: I don't get it....

you have to buy an HPI CDI but dont use it just HAVE it sitting around, either that or another option would be to put a garden hose as far into your exhaust as you can then turn it on until you see water coming out of your carb or something.

you might also try hooking an iphone to the garden hose first.

Re: I don't get it....

Like “Funkenet” Hosfield /

^

Re: I don't get it....

possible air-leak still, maybe intake bolts got loosened while fixing the carb...

also id check the reeds....

Re: I don't get it....

Wow I feel like an idiot for never playing with the points before. I took off the cover and had one of those "well there's your problem" moments. The points weren't even opening!! . I watched the puch timing vid, followed the instructions, and bingo!! My ol' Puch is faster, a lot faster than ever!! THANK YOU ALL.

Re: I don't get it....

Like “Funkenet” Hosfield /

Nice. You are a quick learner. It took me forever to time my points.

Re: I don't get it....

Likely the reason the points quit opening is that the rub block on the points assmbly wore down from the cam on it. Might be good to get new points but in either case put a dab of grease on the cam so that as it turns that grease gets deposited on the leading edge of the points rub block so it doesn't wear so much

Re: I don't get it....

Like “Funkenet” Hosfield /

yup. or ditch the points and get a CDI but those have just as many problems.

Re: I don't get it....

- Summerai - Drew /

^ true.

Re: I don't get it....

trevor stull /

premix derelicts!!!1

Re: I don't get it....

Saw you and your maxi on my way to work the other day, sounded great accelerating through the light you were stopped at. Glad to hear ya got her runnin right.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account