Trail tech vapor speedometer mount on Puch

Hey guys. I just got my Vapor in from treats and i hooked it all up except for the speedomer magnet on the wheel. How are you guys hooking it up? Did you have to make your own bracket? Im thinking I will have to do that to mount it to the spokes so that it is close enough to the sensor to read it. My rpm's at idle bounce all over the place on the readings too. Anybody else have that problem? I tried wiring it into the stator, and wrapping it around the spark plug wire and got the same results. Any pics of your magnet bracket setup on spokes would be much appreciated.

Re: Trail tech vapor speedometer mount on Puch

Mike Whorton /

anyone?

Re: Trail tech vapor speedometer mount on Puch

read up on the tach readings.

everyone is different.

might get some interference, some have to wrap more and some less.

Some people do better on the 1 setting, others on the 2.

As for the speedo, it's up to how crafty you are.

I have non stock wheels on my maxi and so I made a bracket that bulted onto my rear hub, and have the magnet on the rear gear.

worked like a charm for me.

Re: Trail tech vapor speedometer mount on Puch

Mike Whorton /

Just an update to maybe help out anyone else who may be installing one of these. The way I got the speedometer to work was by drilling one of the holes out in the fork for the fender bracket and installing the sensor there. I wound up using a bicycle speedometer spoke mount little clamp for the magnet on my wheels. It works perfectly. The supplied bracket was for an atv or something and it was pretty useless. Hope this helps someone else.

Re: Trail tech vapor speedometer mount on Puch

Just picked up the Vapor.. got any pics of the setup you used to get it working??

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account