Weird Polini Jetting Issues. And Gearing.

Set up.

e50, Polini, Matched.

Modified estrol.

15mm Bing, Polini Reeds..

Currently 88 jet, Clip second from the top.

I have been slowly working my way down from a 96. The 90 felt great on the top end, but was oviously rich on the idle. Went down to an 88 and it idles beautifully, but isn't getting enough gas on the top end (past 3/4 throttle).

So, I am thinking I have a small air leak somewhere. Any ideas?

Also! Having never or even ridden a polini before but doing all appropriate research I am shocked by how torqey this engine is.

Started with 14x45 gearing (city bike - way too extreme), went to a 16x45 felt like it was still pulling too hard, now I am at 18x45, and it still have amazing lowend with some great top end, but I think I could go steeper and still have decent lowend.

What're other people riding with the polini?

Re: Weird Polini Jetting Issues. And Gearing.

you need to adjust your need. Get the top end right, then adjust the needle position to get the 1/4 to 3/4 right

Re: Weird Polini Jetting Issues. And Gearing.

i bet you just need to lower your clip dude. All the way to the top is the leanest setting.

Re: Weird Polini Jetting Issues. And Gearing.

Sorry, this might start a blurry of dumb questions, but setting the needle will help dial in the idle as well?

Re: Weird Polini Jetting Issues. And Gearing.

slightly, yes. i was helping tune that same setup but with a n8p and there was a huge airleak at where the bing clamped on. threw jetting for a loop, it sort of sucked. but then it ripped.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account