Is this a condensor problem? (on a kitted peugeot)

So I've been working on tuning my peugeot build: polini kit, polini case, simonini exhaust, phbg, polini weights/spring. Recently it suddenly went from running sorta ok but the jetting wasn't right (trying to dial it in), to running really poorly. All I was doing was riding and tweaking the idle screw, I of course turned it back to how it was with no effect. Basically it will idle fine, but once I try to give it gas it will want to die, if I give it enough gas it won't be able to die but it will run really rough. I'd almost say it was "8 stroking," like going a whole bunch of revolutions between firing, much worse than normal 4 stroking, and then firing really hard. I didn't change the jets or needle and it is running way way worse then it was before. Only thing I can guess is condensor or other electrical problem?

Re: Is this a condensor problem? (on a kitted peug

If you have the stock ignition on there get rid of it. The cheap route is to put a Puch or Bosch magneto coil inside the mag and then have a external ignition high tension coil. You can have a external condensor also. Big difference, hot spark and way easier to jet. Lots of old threads on this conversion to search for

Re: Is this a condensor problem? (on a kitted peug

I have the 5 coil ignition so I was told I didn't need to bother switching to Puch. I have brand new points but stock everything else.

Re: Is this a condensor problem? (on a kitted peug

is your timing ok? maybe your flywheel slipped a little.

Re: Is this a condensor problem? (on a kitted peug

Good point I didn't think about that possibility.

Re: Is this a condensor problem? (on a kitted peug

timing or almost DEFINITE condenser problem

Re: Is this a condensor problem? (on a kitted peug

o and by the way, be careful timing that 5-coil, it can be very difficult!!!!! the cam has a very long dwell time so the points are open for a long time, be careful and know exactly when they open.

Re: Is this a condensor problem? (on a kitted peug

my timing slipped so bad once it ran backwards

Re: Is this a condensor problem? (on a kitted peug

just like an old two-stroke boat motor!

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account