k-star kit install - LOUD pinging/knocking

Pablo Maurer /

Just got done bolting a 70mm k-star kit to my maxi 2 speed. On startup, it immediately began making a horrendous pinging - think if you hit the heat sink with a screwdriver - that sort of resonating pinging. i shut it down. if you turn the motor over by hand, you can hear the noise right around TDC, during about 1-2 degrees of rotation. sounds, like i said, like a pinging or something. Only makes the noise when compression is present - if you pull the plug out or take the head off the motor turns over smoothly...feels like there is just a little play around tdc and a light little knock as it comes down but nothing other than that. Anybody have any ideas? I haven't pulled the cylinder back off but have no idea where to start.

Re: k-star kit install - LOUD pinging/knocking

put on a few more base gaskets. these kits always ping with only 1 base gasket.

Re: k-star kit install - LOUD pinging/knocking

Jake Shaughnessy /

yep, u need another base gasket

Re: k-star kit install - LOUD pinging/knocking

search kstar. there's a huge thread about this kit and symptom. I've been battling this noise for a long time. i 've had up to 7 gaskets. it doesn't really seem to help. i think you just need 1 or 2 gaskets. I chamfered the intake and exhaust ports real good. that seemed to help!!

Re: k-star kit install - LOUD pinging/knocking

raise the kit 2mm (2 base gaskets should be about right) and chamfer all your ports!

Re: k-star kit install - LOUD pinging/knocking

i got a k star with one base and one head gasket it kinda pings a little but ive been riding it. piston looks fine i thought mabe just that was the way it sounds, i kinda scraped at ports with a nail file. they were kinda champerered, should i take it apart and add more gaskets? ive probly ran about 3/4 tank of gas throuht it

Re: k-star kit install - LOUD pinging/knocking

That all depends, I runs my first piston and ring (luckily not the cylinder) before I chamfered my ports. I'm only running one base gasket with no pinging after the time spent makng everything nice and smooth

Re: k-star kit install - LOUD pinging/knocking

its all about the chamfering on this kit boyz!! i chamfered when I first put the kit on but went back and did some more and finally the clinking sound is gone. lame but i guess thats how it is!!

Re: k-star kit install - LOUD pinging/knocking

Run one gasket and live with it.

Re: k-star kit install - LOUD pinging/knocking

Are you sure its not just a bad wrist pin bearing. Seams odd to me to be saying its the ports when it does it at top dead center.

Re: k-star kit install - LOUD pinging/knocking

Pablo Maurer /

it sort of sounds like a wrist pin - it's just SO effing loud. I will try more gaskets tomorrow and see if that helps. I'll let you know.

Re: k-star kit install - LOUD pinging/knocking

dude gaskets won't help. check it again it ain't tdc!! its the ports!! chamfer that bitch like a motherfucker. seriously! more gaskets fuck up the timing and make it slow and hot!! been there done that!! don't live with it! fix it!

Re: k-star kit install - LOUD pinging/knocking

noise canceling head phones

Re: k-star kit install - LOUD pinging/knocking

Pablo Maurer /

I'm gonna drag the cylinder out to the shop today and chamfer the ports. That'll give me a chance to install some studs in the cylinder anyways. I'll let you guys know the results - i'm going to bolt it up again with just one base gasket and see how it runs. I mean i would doubt it's a bad wrist pin bearing - i had no noise whatsoever with the 65cc metrakit that was on this bike before.

Re: k-star kit install - LOUD pinging/knocking

If it only makes the noise when the spark plug is in at TDC, it IS hitting the plug. Add another base gasket. Chamfer the ports to help the life og the rings too.

Re: k-star kit install - LOUD pinging/knocking

Ive got over 400 miles on one, not to mention im not very nice to it, I has no worries on it.

Re: k-star kit install - LOUD pinging/knocking

What is chamfer, excuse me for being a noob. Is it just rounding ports edges on cylinder instead of sharp edges? what tools do you use to do this, was wondering cause my kit does same thing.

Re: k-star kit install - LOUD pinging/knocking

Pablo Maurer /

Alright so I chamfered the ports. The noise lessened slightly but is still there. I used a rotary tool do dull the port edges but didn't get carried away with it - I suspect I should've ground out a bit more....

I actually don't think it has anything to do with the base gaskets - i pulled the head off in the position where the noise occurs (like i said you can even hear the noise spinning the motor by hand) and the piston is basically in the middle of its travel - right around the ports. So I'm assuming the "ping" is the ring meeting its maker at the hands of the not-chamfered-enough edge.

I'm going to ride it as is this weekend, then unbolt it all and take it out to a machine shop by my place of employment and have them grind it down more/professionally. Pics to follow.

Re: k-star kit install - LOUD pinging/knocking

ok, I thought the sound was gone but after it gets hot the clink is back. maybe we're just supposed to deal with it like the other guys said. the sound is NOT from hitting the spark plug. it happens a half an inch away from tdc and only when the plug is in!! its really weird but I guess normal for this kit since almost everybody has the same problem!!

Re: k-star kit install - LOUD pinging/knocking

What did you ever find out about this? I bought a 50cc high comp head to go on my stock jug E50.. New piston, rings, gaskets, aviation gasket sealer, = Metallic Ping shit noise... i dont get it? What to do? I feel like puttin my #22 back on

Re: k-star kit install - LOUD pinging/knocking

ok... weird.. Lol.. I wont even touch up any ports on the inside of the jug.. I honed it. thats all i thought it needed. Im sure if i took the time to champfer the ports and get those edges ... It would not do a damn thing. Just my guess. Maybe im wrong. Mine felt fine though. But thoise noise sounds very metalish and Tick/clak/pingish... I dunno. Im gonna break it in and ride it till it blows. we will see how long or what the deal is..

My other main issue tonight was found while was letting her runn hot for a while. I was leak testing with carb cleaner.. Everything was tight EXCEPT FOR THE FUCKIN INTAKE to CARB connection... Nice Bing Carb (germany) Fitting up to a shitty cast made in Taiwan 15mm Intake ... well the shitty Taiwan intake must not seal 100% onto the carb because it had a major leak. Spraying that spot was a instant -Kill... So i used motoseal permatex grey and sealed that connection.. hopefully that will work. im just going to tune it and let the Fucker blow up now :P

Re: k-star kit install - LOUD pinging/knocking

Don't worry about the noise. I have put thousands of miles on kstars with NO SEIZES or catastrophic failures at all. They are loud kits, ignore it.

Re: k-star kit install - LOUD pinging/knocking

yeah. mine sounded like shit. chamfered good and ran it. it kinda went away some w/ a few hundred miles.

my buddies k star shot a bunch of sparks out the tailpipe the first night he rode it, and he has been riding it for months w/ a stripped intake stud. those kits are pretty bomb proof if you don't do any thing too stupid.

Re: k-star kit install - LOUD pinging/knocking

They are really tough. I have one I just put together and I had it to 430 deg, runs good no seize and it only has 50 miles on it so far. Not that its good, but show they're tough

Re: k-star kit install - LOUD pinging/knocking

still to this day... No issues.. bikes runs and hasnt seized, scuffed or anything. just makes noises here and there

Re: k-star kit install - LOUD pinging/knocking

campeona del mundo /

man i ono why sooo many of these threads always pop up.

kstar/tccd/dmp/ any piston port 45mm kit pings like a motherfucker. after about 600-1000 miles the pinging gets really loud...replace your piston, give your cylinder some nice cross hatching for the new ring, chamfer and enjoy another 600-1000 miles of high pitched annoying pinging. i went through 2 pistons (after the 2nd one i did very minimal porting) before selling it to a friend who is rippin hard on it to this day.

Re: k-star kit install - LOUD pinging/knocking

Chamfer the ports, check the squish with some solder, run the correct plug, and make sure your ignition timing is set right.

If you do all of that, you won't have pinging... unless you have really high compression and run low octane fuel. I'm guessing that's not your problem though.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account