Newly Installed Puch Polini kit with "ping&qu

ಠ_ಠ Jon Folks ಠ_ಠ /

Hello, I just installed a Polini kit on a ZA50. I just started it up for the first time, and I noticed a "ping" sound. It is a metally sound, like if you hit a screwdriver on the cylinder head. It follows the revs of the engine. Yes I didn't forget the head gasket. Whats the deal?

Setup:

Polini kit

Simonini Exhaust

15mm Bing with 102 jet (too big probably)

Matched ports

Stock Head, stock timing.

Re: Newly Installed Puch Polini kit with "pin

base gasket?

Although we are talking about ZA50 here....many possibilities for clunking sounds :]

Re: Newly Installed Puch Polini kit with "pin

ಠ_ಠ Jon Folks ಠ_ಠ /

Nope I didn't forget any gaskets. It is a ping sound. It corresponds with every revolution and follows the engine speed. ping ping ping pingpingpingping

Re: Newly Installed Puch Polini kit with "pin

ಠ_ಠ Jon Folks ಠ_ಠ /

I should note it is not overly loud, but I noticed it right away.

Re: Newly Installed Puch Polini kit with "pin

well ,it might not be pinging, sometimes you will get ring slap with thones engines...and thats pretty normal.

you could also be hearing the reedvalve, since your bike didnt have one before

but if its actully "pinging" as in detonation..you just need to use a higher octane fuel , midgrade should do the trick, or just get some FRESH gas..not 2 week old gas fresh gas.

Re: Newly Installed Puch Polini kit with "pin

Nah -

That's the Polini 'sound' mine made the same exact sound when I dropped it on there. 1200+ miles later and it's still a champ.

It's just a new deal for you, man. Welcome to the world of Polini.

Re: Newly Installed Puch Polini kit with "pin

What plug are you running?

Re: Newly Installed Puch Polini kit with "pin

its the polini "tin" sound i bet they don;t sound solid at all when they r new

Re: Newly Installed Puch Polini kit with "pin

Yeah, but just to be sure, what plug are you running? I had two guys come into the shop this week, both were running BP6hs plugs and the piston was hitting the electrode...GROSS.

Re: Newly Installed Puch Polini kit with "pin

what you mean you cant just use any old plug from home depot lol

Re: Newly Installed Puch Polini kit with "pin

ಠ_ಠ Jon Folks ಠ_ಠ /

I'm running a Bosch plug... but I don't see a marking on it. I'll pull the head and check it out...

Re: Newly Installed Puch Polini kit with "pin

ಠ_ಠ Jon Folks ಠ_ಠ /

Oh yea, what plug should I be running? I'm looking at buying some new spares. Bosch W5AC?

Re: Newly Installed Puch Polini kit with "pin

) Cupermcnewbster ( /

NGK, either B6HS, B7HS or B8HS. 6 is hottest, 8 is colder.

Re: Newly Installed Puch Polini kit with "pin

ಠ_ಠ Jon Folks ಠ_ಠ /

With my setup, should I run a hotter or colder rated plug?

Re: Newly Installed Puch Polini kit with "pin

B8HS

the puch polini is a noisy kit. It's nothing to be alarmed by.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account