Tomos A3 Not Running - Timing?

Tadd Good /
This single post is part of a larger thread. Start from the top or view this post in context.

Last winter I picked up my first moped. 78 Tomos A3. Of course, it had the same story every moped has. It just ran over the summer but hasn't been started it a bit.

I have/had 0 mechanical knowledge going in but I've learned quite a bit over the winter. I've checked tutorials, read Fred's guide, searched these forums, and I'm finally breaking down to ask for some help.

I have a nice blue spark.

I replaced the encarwi with a brand new sha from treats.

I have compression but I've only done the thumb test.

The next thing on my list is cleaning the points and checking the timing, which is very intimidating to me. After watching some videos on timing on a puch (all I could really find) I took off my flywheel cover and can't really tell where the points are on my Tomos.

When I rotate the flywheel counterclockwise you can hear a bit of a hiss of air coming out from where the exhaust mounts onto the motor (I have it off to clean as it's full of carbon).

Does anyone have a photo of a Tomos A3 flywheel and can show me what I'm looking for? Is this the logical next thing to check off my list? Any other ideas? Would old fuel make a difference?

I've had this thing for far too long to not have it even fire up once. Help!?

This single post is part of a larger thread. Start from the top or view this post in context.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account