Peugeot 103 weak spark

Got a 5 coil Peugeot that’s getting a pretty weak spark. Replaced points and condenser, unplugged kill switch and wiring harness only wire connected is to coil. Tried different plug boots, plug wires, used a Puch ht coil, still the same. It starts and runs but having tough time tuning it getting lots of carbon build up. Any ideas appreciated.

Re: Peugeot 103 weak spark

Resistors in the anti parasite cap is a wear item. Try a resistor plug and just a plain cap without a resistor in it.

Re: Peugeot 103 weak spark

Does the 103 require any HT resistance ?

If not , run a non resistor plug along with a non resistor cap .

Also , check clearance between the stator coil cores and the flywheel magnets .

Set them as close as possible with out touching .

Check that all grounds are shiny clean and scratch tight .

Good ground motor to frame .

And , clean those new points with brake cleaner . Only takes a fingerprint to foul points .(edited)

Re: Peugeot 103 weak spark

Michael Branscombe /

your test coil is also bad/weak? what color spark is generated at the plug? Snappy and blue?

Re: Peugeot 103 weak spark

Got a 5k cap and regular b6hs plug, I'll try the resistor plug and unresisted cap. Everything else is clean and set correctly I believe. The spark is barely visible in the shade.

Re: Peugeot 103 weak spark

> Rebel Moby Wrote:

> -------------------------------------------------------

> Resistors in the anti parasite cap is a wear item. Try a resistor plug

> and just a plain cap without a resistor in it.

Just wanna say thanks Moby, this worked for my Pug.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account