Jumped A Spree With a Car and Have Issues Now

I fucked up. I jumped a Honda Spree with a car and turned the car on. Now the lights won’t turn on and the electric start won’t work. I checked the fuse and it looks perfectly fine. What did I fry?

Re: Jumped A Spree With a Car and Have Issues Now

Well a spree is 6v and the car is 12v, so who knows. regulator/rectifier/battery?

Re: Jumped A Spree With a Car and Have Issues Now

Check the fuse with an ohm meter..it might look good but not..you probably blew out the bulbs on the lights

Re: Jumped A Spree With a Car and Have Issues Now

Thanks guys. I will replace the fuse first and then update the post. Feel like such a jackass.

Re: Jumped A Spree With a Car and Have Issues Now

The fuse has no connectivity so I am hopefully assuming that is it. Going to grab a new one tomorrow and trickle charge the moped battery.

Re: Jumped A Spree With a Car and Have Issues Now

Blew reg/rectifier.....been there before

Re: Jumped A Spree With a Car and Have Issues Now

Brandon Weiss (Detective brandon to you) /

Lol, took me a second...I thought you jumped over a spree with a car.

Check the fuse again?

Re: Jumped A Spree With a Car and Have Issues Now

Overpriced Parts /

Yeah jumping vehicles if not done perfect will damage your vehicle, I haven’t jumped a vehicle for a long time,

Re: Jumped A Spree With a Car and Have Issues Now

Barack Obama /

I though u actually jumped the car

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account