1977 A3 Tomos spark, but no points spark

I recently purchased a 1977 Tomos A3. I initially had no spark at plug and points, but my headlight and brake light would light up when I turned the engine.

I disconnected lighting to make sure it was not a ground issue. Still got no spark. I thought maybe the coil on the stator starter coil was bad, so I jumped a wire from the light stator coil on the bottom, to the top, essentially using my headlight wire to start the motor.

I GOT SPARK! and consistent spark. Still no spark at the points. Set points and timing to the best of my knowledge (first time). Plugged the spark plug in and still no engine fire. Good compression as well and fuel delivery is fine.

I'm thinking bad condensor or points. Stators are hard to find for this and pricey. Any other troubleshooting you guys recommend?

I've read Fred's guide and it has alot of good information, but I wanted to ask the community for a more advice to fix due to my issues. Thank you!

20200316_195130.jpg

Re: 1977 A3 Tomos spark, but no points spark

http://www.myronsmopeds.com/category/service/wiring-diagrams/

mayxh your up, may have ext. ignotion ground thru brake bulb filament. check for spark at plug not at points.

Re: 1977 A3 Tomos spark, but no points spark

20200316_213041.jpg
20200316_212936.jpg

Upon further investigation, I could not get continuity between the wire from the top wire coil to the condensor. (Photo attached)

20200316_212936.jpg

I also found part of the stator plate corner was broken. Would this affect anything? The stator is still secure when bolted up. (Photo attached)

20200316_213041.jpg

Re: 1977 A3 Tomos spark, but no points spark

that a3 moped motors been hammered on, terrible. anyways, you need a new stator plate to secure the coil. the vibrations ate thru the outer sheathing grounding the spark on the condenser (back of black wire), that little chew mark. so many things to do...lap flywheel, service points, polish cam, change crank seal and cleaning off crank rust. theres a buy sell forum on ma u can post there for a used plate.

Re: 1977 A3 Tomos spark, but no points spark

Ya she isnt the prettiest. Thank you. I will do the service on those and get a new plate. Would the brake light ground still be relevant if those wires are disconnected?

Re: 1977 A3 Tomos spark, but no points spark

♣Slew Foot♣ /

Nothing gonna run. Without working stator. Ground should go to frame.

Re: 1977 A3 Tomos spark, but no points spark

There are several brand stators used on A3 engines, make sure to match your replacement parts. What does it say on the flywheel?

Re: 1977 A3 Tomos spark, but no points spark

♣Slew Foot♣ /

Looks like a cev. Cc I might have 1

Re: 1977 A3 Tomos spark, but no points spark

So I ended up getting a new stator and flywheel, eliminating the points system. Fired right up first kick!

Now I am having a fuel flooding issue and gears seems to be clunking inside, or stuck in second gear maybe? Need to take it apart and take a look.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account