E50 no start when hot

I’m running an e50 with a 50 kit, proma circuit pipe, delorto 1412. It’s been running fine until recently. It doesn’t want to idle, and after running it for 10+ minutes it won’t start back up. I have to wait 20-30 minutes for it to cool down just to get it started. So I’ll hit a stop sign, then it’ll die and I have have to let it cool down before I get it running again. It has and b7 plug and the color looks good and the plug looks clean. Thinking it could be a point gap issue. Any ideas?

Re: E50 no start when hot

Check your Condenser or just do the external condenser setup and be done with it. You can get one at your local auto parts store won't take you more than 30min to setup and you'll have eliminated that variable.

Re: E50 no start when hot

Wesley Ambrosini /

Are you sure it's the heat and not the bowl emptying?

Re: E50 no start when hot

Pushrod Fifty /

They loose value like crazy with heat when they are old.

Re: E50 no start when hot

Yes it’s definitely something electrical. I’m also thinking could be a bad coil. Gonna try a few things out.

Re: E50 no start when hot

UPDATE: I up jetted and sealed up an air leak where the carb meets the intake. That fixed my idling problem, so now it idles just fine.

But the not starting when hot problem still remains. It’s most likely something electrical. I’m thinking it’s either a bad condenser or a bad high tension coil. Could just be I need a hotter spark plug. I’m gonna try a few things out.

Re: E50 no start when hot

Richard Eberline /

Alex said, Check your Condenser. So keep checking everything but the bad part.

Re: E50 no start when hot

Moped Lar (OFMC) /

Change the friggin condensor already.(edited)

Re: E50 no start when hot

I thought "bad condenser" when reading the title of this thread, so you'd better start with checking the air pressure in your front tire.

Re: E50 no start when hot

I checked the front tire and it it was filled with proper amount of spaghetti.

Re: E50 no start when hot

Turns out it was a bad coil folks. Easy fix!

Re: E50 no start when hot

Richard Eberline /

External HT coil?????? If you cross the positive and the ground what happens? What are the ohm readings, for the Primary and secondary?

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account