new kit new problems e50

I switched over to a kstar 70cc kit and once i put the head on and bolt it on, when i go to pull the clutch and pedal its super tough almost like its seized but if i take the head off and do it its fine. the cylinders not marred up or anything and the piston moves back and forth fine so i now its not seized. Im stuck on this problem. any advice is appreciated

Re: new kit new problems e50

How much compression does the motor have ?

Re: new kit new problems e50

> P D Wrote:

> -------------------------------------------------------

> How much compression does the motor have ?

i dont have a tester but it blows my finger away if i crank it

Re: new kit new problems e50

Dirty30 Dillon /

Are you using a stock head, or cut head for the increased displacement

Re: new kit new problems e50

Did you space the squish properly? Piston prolly hitting the head.

Re: new kit new problems e50

> Dirty30 Dillon Wrote:

> -------------------------------------------------------

> Are you using a stock head, or cut head for the increased displacement

cut head 70cc hi comp

Re: new kit new problems e50

> Aaron Blair Wrote:

> -------------------------------------------------------

> Did you space the squish properly? Piston prolly hitting the head.

have a 70cc head gasket in, also sanded the head too

Re: new kit new problems e50

Dirty30 Dillon /

My guess is that your piston is impacting the head.

Re: new kit new problems e50

Any sign of contact between piston and head ?

Get or borrow a compression tester .

You can blow a finger off a hole with what you have in your lungs . Doesn't tell much .

Re: new kit new problems e50

> P D Wrote:

> -------------------------------------------------------

> Any sign of contact between piston and head ?

>

> Get or borrow a compression tester .

>

> You can blow a finger off a hole with what you have in your lungs .

> Doesn't tell much .

not that i can tell, im about to order another head gasket and see if thats the problem

Re: new kit new problems e50

does anyone know the specs to the 70cc head, measurements of the squish? i have it 40mm and want o double check im not using the wrong head

Re: new kit new problems e50

Solved: i had 2 50cc heads, one i thought was 70cc and a 70cc head that i thought was 50cc. took some measurements and 2 were the same, the last was much much different.

Thanks everyone

Re: new kit new problems e50

> josh n Wrote:

> -------------------------------------------------------

> Solved: i had 2 50cc heads, one i thought was 70cc and a 70cc head that

> i thought was 50cc. took some measurements and 2 were the same, the last

> was much much different.

>

> Thanks everyone

You're welcome , but , that^ doesn't solve anything except your confusion . LOL

What did it take to make your motor easier to start ?

And , how can heads be the same , but much much different ?

Re: new kit new problems e50

> P D Wrote:

> -------------------------------------------------------

> > josh n Wrote:

>

> > -------------------------------------------------------

>

> > Solved: i had 2 50cc heads, one i thought was 70cc and a 70cc head

> that

>

> > i thought was 50cc. took some measurements and 2 were the same, the

> last

>

> > was much much different.

>

> >

>

> > Thanks everyone

>

> You're welcome , but , that^ doesn't solve anything except your

> confusion . LOL

>

> What did it take to make your motor easier to start ?

>

> And , how can heads be the same , but much much different ?

2 measured out to be 38-40mm last one was way bigger like it fits a 70cc piston in the squish band, all 3 of them are dirty so they looked the same. Try cranking a 70cc piston with a 50cc head on and it wont go

edit:i have 3 heads, 2 50cc, 1 70cc (edited)

Re: new kit new problems e50

> josh n Wrote:

> -------------------------------------------------------

> edit:i have 3 heads, 2 50cc, 1 70cc

Ahh . You should have said that first . We're not there , looking over your should , to see that . ;)

The devil is in the details , minor as they might be .

Re: new kit new problems e50

> P D Wrote:

> -------------------------------------------------------

> > josh n Wrote:

>

> > -------------------------------------------------------

>

> > edit:i have 3 heads, 2 50cc, 1 70cc

>

> Ahh . You should have said that first . We're not there , looking over

> your should , to see that . ;)

>

> The devil is in the details , minor as they might be .

Sorry i thought i typed it out in second to last response, guess i wasnt clear enough

Re: new kit new problems e50

> josh n Wrote:

> -------------------------------------------------------

> Sorry i thought i typed it out in second to last response, guess i wasnt

> clear enough

No worries . I've been less than clear more than once .

Painting a picture that others see as we do , sometimes take a bit of doing . :)

Re: new kit new problems e50

I have a 50cc head on a 70 kit. I was going 41MPH, 2 nights ago. Pulled clutch to see why it grabbed so EARLY, screws were all the way out. My compression is 110. Guess I need another head? Couldn't test tonight (float stuck).

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account