brand new malossi 62 cc kit piston sticking!

i picked up a 62 cc malossi kit and high compression head kit from treats. mounted up to a sachs504 bottom end with an adapter and some minor dremeling.

oiled up the cylinder and piston liberally

when installing. piston slid into cylinder easily when installing, but when trying to pedal start, it sticks and locks the rear wheel.

i checked the starter clutch and it’s ok, have a single cable as original jug had decomp; this kit doesn’t.

for the life of me, i don’t know why it is sticking in the cylinder. i took the head off a few times to verify: starts at top, it gets stuck at bottom of rotation and won’t fire at all.

i did verify that the piston ring is on properly and lined up with the locating pin.

i haven’t been able to find any posts about this specific modification on my application.

please help.

Re: brand new malossi 62 cc kit piston sticking!

Piston hitting the case?

Re: brand new malossi 62 cc kit piston sticking!

so here’s the deal, I gapped the piston ring, was like butter. oh so smooth.

still, piston was getting stuck at bdc.

had a few buds over and after a few barley pops we figured out that the BACK of the piston was HITTING THE CRANK at bdc.

needless to say, i Dremeled and sanded all night and matched the back length of the piston to the previous piston since we are only increasing bore, not stroke, with the kit.

the stroke is 42 on a 504, 44 on a 505. i’m

going to reinstall everything tomorrow morning. wish i had a 505, oh well...

to think, we thought it was a clutch issue... thanks barley pops. hopefully this will be helpful to someone, some day

stay tuned

knoll

plug & play

Re: brand new malossi 62 cc kit piston sticking!

got her running! boy does this kit RIP.

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account