Electrical Nightmare

Drake Abrahamsson /
This single post is part of a larger thread. Start from the top or view this post in context.

My lights aren’t working but my bike runs. I’ve been able to identify a “trail tech dial-a-brightness AC voltage regulator”. I don’t have brake lights or a horn- just the tail lights and headlight. I can’t find a wiring diagram for my setup. The owner said it was a 12V system and the regulator also points me in that direction. don’t have much electrical experience at all so the diagram may be under my nose but I just can’t tell really what I’m looking at. I’ve attached some horrible horrible pictures of how the wire terminal looked before I took it all apart, but I can’t even guarantee that it worked before that because the moped wasn’t running and there was no taillight whatsoever. I spent a lot of time and used a bunch of other pictures I took to put it back together so I’m positive I put it back together how I got it. There are a lot of connections into the terminal that aren’t connected to anything on the other side. I bought a new taillight and replaced the 6V bulbs that came with it with 12V ones. The headlight is a 12V H3 halogen 55W bulb. The wires are nearly all awful so I wouldn’t be opposed to rewiring the whole system. Any guidance/resource provision would be greatly appreciated. Thanks!

FC531995-CA3B-4880-A10E-10D44DF5D500.jpeg
93A01B60-56CD-4CCD-BE21-A61D3CF67838.jpeg
This single post is part of a larger thread. Start from the top or view this post in context.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account