Headlight, Brake Light and turn signals all just went out.

09 Tomos Targa LX, all his lights went out. Horn works. Headlight, Front and rear Turn signals, and rear light and brake light. None are working, only the horn. Can't seem to find any fuses on it. Please, please help.

Re: Headlight, Brake Light and turn signals all just went out.

Check all your connections and grounds

Re: Headlight, Brake Light and turn signals all just went out.

Checked, but everything went out at once. Speedo light, head light, tail light, brake light and turn signals. I am thinking a relay or a fuse but I can't find a fuse on this thing.

Re: Headlight, Brake Light and turn signals all just went out.

Maybe a wiring diagram will help :

https://www.mopedarmy.com/wiki/Tomos_wiring_diagrams

Re: Headlight, Brake Light and turn signals all just went out.

♣Slew Foot♣ /

If it's the points model take the blue black wire from the tail grounded the frame take the blue black where it goes from the Magneto and grounded the ignition block double check the coil afterwards to make sure it's still working it might be your coil failed to check it you can run voltage through it from a 9 volt and it should magnetized if it's good if it's bad it will heat up where the short is but you have to isolate the circuit to test.

Re: Headlight, Brake Light and turn signals all just went out.

♣Slew Foot♣ /

Oh yeah and your blinker thingy the round cylinder thing could have went bad you can bypass it and if the lights work it was the blinker thingy you can replace it with an old 70s one from a Chevy

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account