Piaggio si drive belt and rear hub problems

Matthew Tramer /

Hi, about a month ago I started fixing an old piaggio si that my grandparents had in there farm. I’m really near the end but a new problem has arose. The drive belt, that previously had moved freely in tandem with the rear wheel hub has stopped spinning with it but it does move freely when I manually spin the variator. Another detail is that the drive belt isn’t flush and at the top of the rear pulley. Finally, when I move fast enough with the moped the back wheel sort of gets stuck but at the same time the drive belt and the rear wheel unit do move in tandem.

If any body has any suggestions they would be greatly appreciated!

Re: Piaggio si drive belt and rear hub problems

sounds pretty normal to me. front pulley = front variator. rear pulley consists of clutch, clutch bell and starter shoes. when u pedal fast enough or run w the bike fast enough the starter shoes expand and turns belt to turn motor. go fast.

Re: Piaggio si drive belt and rear hub problems

Matthew Tramer /

The thing is that after a few feet of running the rear wheel locks

Re: Piaggio si drive belt and rear hub problems

The decomp valve may be sticking, assuming your pulling the lever as the engine starts to turn over.

Re: Piaggio si drive belt and rear hub problems

make sure your motor turns freely, with compression that is.

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account