Vespa SI won’t run right

Kristian Lomeland /
This single post is part of a larger thread. Start from the top or view this post in context.

Hi!

I’ve been having alot of issues with getting my Si to run right, and here is the list of what i have checked and done:

- Got rid of the Ebay engine case, and got a used OEM one.

- Checked all ignition components with multimeter, replaced condencer. Otherwise all good.

- New gaskets in engine, also using head gasket.

- New piston and rings.

- Set points to spec, and timed it. Checks out fine.

- Mini circuit lowboy exhaust because the old one was rusted out.

- SHA12.12 carb upjetted to 56.

After all this it started and idled fine. Four-stroked a bit, and had no low-end power what so ever. Had to run with it to get the engine to take over.

Then the banjo fell off due to destroyed threads, and the jet threads was also very bad.

This leads us to where we are now.

I had a SHA13.13 laying around from another vespa. Bought both a hi flow stock filter and a malossi air filter to go with it. Tried with the Malossi filer and the same 56 jet. It runs better, but still bad low end power. Will not idle when cold, only when warm. Also, the moped is a "fast" version, and now it does not hit 45km/h(28mp/h) as it do stock. Lights work as they should.

I am starting to get real tired of it, and would be forever grateful for some helping words from you guys.

Here is a pic of my newly restored Vespa, only thing left is to get her running.

This single post is part of a larger thread. Start from the top or view this post in context.
Subject Written By Posted
  Vespa SI won’t run rightTopic by: Kristian Lomeland Kristian Lomeland 07/12/19 04:47PM
  Re: Vespa SI won’t run rightRe: Richard Eberline Richard Eberline 07/12/19 09:36PM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/13/19 01:56AM
  Re: Vespa SI won’t run rightRe: pat splat pat splat 07/13/19 12:45AM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/14/19 04:12AM
  Re: Vespa SI won’t run rightRe: pat splat pat splat 07/14/19 01:15PM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/16/19 05:07PM
  Re: Vespa SI won’t run rightRe: pat splat pat splat 07/16/19 07:29PM
  Re: Vespa SI won’t run rightRe: live ɘvil live ɘvil 07/16/19 08:27PM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/17/19 03:15AM
  Re: Vespa SI won’t run rightRe: Bad Cadillac™ Bad Cadillac™ 07/17/19 07:55AM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/17/19 03:22PM
  Re: Vespa SI won’t run rightRe: Bad Cadillac™ Bad Cadillac™ 07/18/19 06:47AM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/18/19 06:37PM
  Re: Vespa SI won’t run rightRe: live ɘvil live ɘvil 08/16/19 03:36AM
  Re: Vespa SI won’t run rightRe: Bad Cadillac™ Bad Cadillac™ 07/18/19 07:02AM
  Re: Vespa SI won’t run rightRe: Bad Cadillac™ Bad Cadillac™ 07/18/19 07:11AM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/19/19 06:30AM
  Re: Vespa SI won’t run rightRe: Bad Cadillac™ Bad Cadillac™ 07/19/19 06:49AM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/19/19 06:52AM
  Re: Vespa SI won’t run rightRe: Kristian Lomeland Kristian Lomeland 07/19/19 04:47PM
  Re: Vespa SI won’t run rightRe: Donald durkee Donald durkee 08/15/19 02:28PM
  Re: Vespa SI won’t run rightRe: live ɘvil live ɘvil 08/16/19 03:18AM

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account