1980 Motobecane Traveler ignition issue.

Corbin Welsh /

I just picked up a 1980 motobecane traveler. I don’t know anything about French mopeds, but this one is not getting spark.

What should I check first in the ignition system?

Any help would be appreciated!

Re: 1980 Motobecane Traveler ignition issue.

Re: 1980 Motobecane Traveler ignition issue.

No spark is usually a issue with the condenser being cooked on a Moby. Check the wiki for the mod to change out to an external one. Also change the bonding strap and connect it between a intake stud and the lower external coil stud.

Master switch from hell could be corroded.

If you have a resistor cap and resistor spark plug there is too much resistance, chnge one for non-resistor.

Points could just be dirty, give them a clean.

External coil could be kaput, if it is chalky looking that is certainly a possibility.

Antiparasite resistor in the ignition cap cold be dead, might need to change that out.

Re: 1980 Motobecane Traveler ignition issue.

♣Slew Foot♣ /

If you do everything and replace the condenser and it's still acts the same way there is a blue wire that runs under the point set it gets yanked and Baird once in awhile and it will mimic a bad condenser

Re: 1980 Motobecane Traveler ignition issue.

Blue wire is the one for the condenser, another reason to remove the old one when installing an external condenser (or at least removing the wire from the old one if you have the 3 coil magneto and it is hidden under coil #3).

> ♣Slew Foot♣ Wrote:

> -------------------------------------------------------

> If you do everything and replace the condenser and it's still acts the

> same way there is a blue wire that runs under the point set it gets

> yanked and Baird once in awhile and it will mimic a bad condenser

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account