Engine dying intermittently after running great

Bruno Trindade /

Jawa 210 (1983 model I think). Just got the carb cleaned up and tuned right (14.12 SHA clone). Idles great (if a little high), starts with one kick. After riding around at about 30 mph for a few minutes, the engine rpms will suddenly start to drop until the engine dies. Opening throttle has no effect. I'm usually able to restart the bike without much problem - the note here is that I almost always check the spark plug cap to make sure it's tight. It generally feels a little wobbly. But I'm not sure this is the issue because sometimes the bike re-starts without me poking at the cap.

Before I go throw any more money at it, I'm going to try a fresh spark plug. Beyond that, I'm thinking cap/boot/wire replacement? Is something in the ignition overheating? Thyristor, coil, .... ? It seems like it wouldn't idle well if it were a spark issue, but I'm out of ideas.

Re: Engine dying intermittently after running great

Blaine- The artist formerly known as Plumber Crack "(OFMC)" /

Before you throw anything electrical at it, i’d check to verify that you’re actually loosing spark when it acts up.

Honestly it sounds like symtoms of a classic fuel restriction. Fuel is able to trickle through the petcock, but the flow can’t keep up with the high flow demand of sustained wide open throttle.

Either crap in the peckcock or the inlet of the carb.

Re: Engine dying intermittently after running great

Also check the gas cap vent.

Re: Engine dying intermittently after running great

Bruno Trindade /

FWIW - I switched out the spark plug with a new one because it was easy and I already had one sitting around. Now the problem seems to have gone away! There's still some very minor unsteady performance, but I'm not sure if that's just normal for a moped with this kind of carb since this is the only moped I've owned. Going to keep fuel issues in mind though - the tank has some rust in it that might be affecting the petcock and carb (a fuel line filter is in there to keep out the chunky stuff).

Thanks!

Re: Engine dying intermittently after running great

Replace the wire to the plug and possibly the cap.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account