turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

hey guys good afternoon , I was wondering if anyone here had or is having the same issue im having . im currently stumped by my turn signals . I tried everything and still can't seem to get them to blink , it seems like the right turn signal is constantly on and the left won't even come on. I replaced the previous 552 flasher unit with a novita 552 and still having the same issue , whats weird is that even if I take off the flasher unit the light on the right still stays on and when I plug the unit in it still does the same. I checked all grounds and they are 100% , I started to rewire and crimp all connections with thicker gauge wires. all lights work though . head, rear and break lights work 100%. any help would be greatly appreciated. I try not to come here to ask for question unless I tried everything. ill place my wiring diagram as well

PS: I checked the switches weld points and they are also perfect and I checked through all the wired and they are also good.

IMG_1360.jpg
977835BC-2545-4C7A-8562-5E1BC8BB3FA3-6596-000004B96297868D.jpg

Re: turn signals not blinking even after replacing flasher unit. right light lit

In my experience if a bulb is staying on and there's no blinking it means the bulb that isn't lighting up is burnt out. You've checked all the bulbs?

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

yes I've checked all the bulbs and even replaced them with new ones

Re: turn signals not blinking even after replacing flasher unit. right light lit

♣Slew Foot♣ /

there has to be a ground fault somewhere in the breaking circuit you have your idol turned up enough right double check the brake sensors and inside of the tail light housing under the reflector and the socket Bowl there may be a ceramic resistor it could be broken sometimes they use it to lower the voltage on your running light

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

My idol is up around 2,000rpms enough where the back wheel won’t spin or if it does it’s very slight , as for the ceramic resistor I don’t think there was one there but I’ll double check , I’ll check my grounding cables again and clean all the contacts to see if that helps aswell

Re: turn signals not blinking even after replacing flasher unit. right light lit

♣Slew Foot♣ /

Yeah my Thomas's that had turn signals that worked the idols were all crazy high you would need to hold your break at idle sorry about the voice app

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

Oh btw this would happen. Even if the switch is on neutral, and I’ll try to raise idle to see what happens too and no worries I appreciate the help so much :)

42285CC9-CB57-4515-94D7-D7A27670DF35.jpeg

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

wow so look at this , I found what looks like the previous owner was trying to jump the right turn signal (which was why it was always on) and once I removed that piece of wire I tried jumping the red cable which leads to the switch and now my turn signals respond to the switch but they still won't blink even at high rpms. the first picture is what I found when I unplugged the rear harness.

IMG_1385.jpg
IMG_1391.jpg
IMG_1392.jpg

Re: turn signals not blinking even after replacing flasher unit. right light lit

♣Slew Foot♣ /

Try wiring in the old flasher unit I usually just use a 70s Chevy or GM flasher unit

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

the one im using is a 552 old style 2 prong unit , its the model this bike uses. from what im seeing online is that the flashers aren't connected to regulators. but since this bike doesn't have a battery im not sure. so I know for a fact that the flasher unit isn't receiving power or not enough power.

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

Has anyone used a flasher unit other than the 552’s ?? If you have on a LX please let me know, I have yet to get the flasher to work , now I’m just using the signals as is (constant power) with no flashing. I pretty much connected the yellow cable to the switch (red) and that powers my turn signals but not flash because somehow the flasher isn’t working

Re: turn signals not blinking even after replacing flasher unit. right light lit

Brandon Weiss (Detective brandon to you) /

Are your turn signal bulbs LED?

If they are, they wont draw enough to cause the flasher relay to go off.

I replaced the bulbs in my tomos signals with LEDs and they wouldnt blink. I switched one in each of the left and right circuit back to incandescent and they flashed.

Re: turn signals not blinking even after replacing flasher unit. right light lit

> Brandon Weiss (Detective brandon to you) Wrote:

> -------------------------------------------------------

> Are your turn signal bulbs LED?

>

> If they are, they wont draw enough to cause the flasher relay to go off.

>

> I replaced the bulbs in my tomos signals with LEDs and they wouldnt

> blink. I switched one in each of the left and right circuit back to

> incandescent and they flashed.

LED bulbs require an electronic relay to function properly .

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

I’m not using LED just the regular bulbs that came with it , even replaced them aswell and nada

Re: turn signals not blinking even after replacing flasher unit. right light lit

It's not a bad idea to use electronic relay in an otherwise stock blinker setup .

Electronic relays require less 'juice' to function , thereby leaving more for other things .

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

That wouldn’t cause any issues with the stock 12v bulbs ?

Re: turn signals not blinking even after replacing flasher unit. right light lit

> Anthony Vargas Wrote:

> -------------------------------------------------------

> That wouldn’t cause any issues with the stock 12v bulbs ?

If you mean maybe a bit quicker on/off and possibly a touch brighter , sure .

If you mean anything negative , no .

I run one in both my FA50 and my XT350 . I ran one in my CB750 . None of which have/had any LEDs .

Picture yourself having to get up and physically touching the TV to change any setting : on/off , channel , volume or any picture quality adjustment . Compare that to using the remote you just found under a couch cushion for all/any of those functions . Maybe you can see the difference .

IOW , the old style thermal relay has to work much more to accomplish the same end .

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

So I just installed the 2 prong electronic flasher and still does not work , not sure what’s going on here . Everything is wired properly as well , anyone have any clues ? Only reason I need turn signals is to get the cops off my back and to let people know where I’m going at night

Re: turn signals not blinking even after replacing flasher unit. right light lit

Might be a good idea to get a multi-meter and test everything involved . Bulbs , sockets , wiring and switches . Check all connections for a scratch tight fit , including the grounds .

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

Yea seems like there’s something wrong with the wiring , know a good multi meter ? A non expensive one?

Re: turn signals not blinking even after replacing flasher unit. right light lit

For what you need , Harbor Freight . Grab an cheapo . meter

Re: turn signals not blinking even after replacing flasher unit. right light lit

skull license plate frame overloading the system with too much bad-ass, happens all the time on tomos

Re: turn signals not blinking even after replacing flasher unit. right light lit

Anthony Vargas /

Hahaha I just laughed so hard. Got to scare off the cars somehow right ? As if the bullet pipe isn’t loud enough xD

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account