QT50 - Ignition/Starting

Coleman Gavel /
This single post is part of a larger thread. Start from the top or view this post in context.

Most of the forums I've searched are pretty old, but I'm going to give this a shot.

I bought a running 79 QT50 a couple weeks ago. Guy didn't have a key for the ignition, a title, or a battery; which I still have to figure out the title issue, but I test drove it and we made a deal. I'm completely new to mopeds but the forums have helped me out so far.

So my issue is, when I got it, it had no working lights on it whatsoever. Not even the headlight when it was running. All the bulbs seem fine. He gave me an extra ignition switch with no key since the one on it was jacked up. I put the new switch on and got a new battery and fully charged it. I disassembled the switch and made the connection, and the oil light came on. Right turn signal worked front and rear, left signal just lit the light on the cluster. Tail/brake light wouldn't work either. But it wouldn't start, if I undid the connection on the switch it would start. Is there something else that may be unplugged? I checked everything over and all the bulbs and everything seems to check out. I'm at a loss here. Any help is appreciated, thanks guys.

This single post is part of a larger thread. Start from the top or view this post in context.
Subject Written By Posted
  QT50 - Ignition/StartingTopic by: Coleman Gavel Coleman Gavel 05/23/19 09:29PM
  Re: QT50 - Ignition/StartingRe: Mac Patten Mac Patten 05/23/19 10:14PM
  Re: QT50 - Ignition/StartingRe: Jack Rutherford Jack Rutherford 05/24/19 11:21AM
  Re: QT50 - Ignition/StartingRe: Stephen Keller Stephen Keller 05/23/19 10:23PM
  Re: QT50 - Ignition/StartingRe: Mac Patten Mac Patten 05/23/19 10:34PM
  Re: QT50 - Ignition/StartingRe: Mark B****** Mark B****** 05/23/19 10:45PM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 05/24/19 11:02AM
  Re: QT50 - Ignition/StartingRe: Jack Rutherford Jack Rutherford 05/24/19 11:24AM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 05/24/19 03:06PM
  Re: QT50 - Ignition/StartingRe: Jack Rutherford Jack Rutherford 05/24/19 10:08PM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 05/24/19 10:16PM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 05/25/19 10:34AM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 05/25/19 01:30PM
  Re: QT50 - Ignition/StartingRe: Jack Rutherford Jack Rutherford 05/25/19 02:55PM
  Re: QT50 - Ignition/StartingRe: Mac Patten Mac Patten 05/25/19 03:40PM
  Re: QT50 - Ignition/StartingRe: Mac Patten Mac Patten 05/27/19 01:16PM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 05/29/19 08:49PM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 05/30/19 09:24PM
  Re: QT50 - Ignition/StartingRe: Mac Patten Mac Patten 05/30/19 09:35PM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 06/07/19 06:39PM
  Re: QT50 - Ignition/StartingRe: Keno Rojas Keno Rojas 06/07/19 06:50PM
  Re: QT50 - Ignition/StartingRe: Coleman Gavel Coleman Gavel 06/07/19 07:42PM

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account