Moped has no spark after being outside in the rain

Ok so today it was raining outside and my 2018 Tomos Sprint moped was getting wet. I had just received a replacement air filter for my old one which had a torn rubber boot where it clamps on the carb. So I took my wet moped in the garage and swapped out the air filters. It started right up and I let it idle for a few minutes and rev'd the throttle a few times. It was working fine so I turned it off and and left it in the garage. About 4-5 hours later when it stopped raining I tried to start it to go for a ride and it wouldn't start. It doesn't seem to be getting spark for some reason. When I try to kick start the engine, the lights go on, I can honk the horn, but don't get spark. Anyone have any idea what could be wrong? It's a brand new Tomos Sprint I bought from 2ndstrokemopeds earlier this year and never had any issues until today.

Re: Moped has no spark after being outside in the rain

Hmmm.i dunno..but I've heard bad things about the new cdi's.

Re: Moped has no spark after being outside in the rain

Check that there is no water in the carb bowl. Could the kill switch have gotten some water in it?

Re: Moped has no spark after being outside in the rain

I took the carb out and completely cleaned it. I wanted to try and bypass the kill switch to rule that out but don't know how.

Re: Moped has no spark after being outside in the rain

Check spark..Pull out the plug, hook it back up to the wire. Ground it to the cylinder...kick her over and look for spark...

If you have somebody to help its easier to have someone kick it over whilst you hold the plug on the cylinder.

Re: Moped has no spark after being outside in the rain

It doesn't have spark. I don't know why though or how to go about trouble shooting it.

Re: Moped has no spark after being outside in the rain

the 2 stroke oil fouls the sparkplugs. you might just have to take out the spark plug and wipe it clean.

Re: Moped has no spark after being outside in the rain

I took out the plug and put a flame to it to dry it out. Still no spark. I also tried a different spark plug. Still no spark.

Re: Moped has no spark after being outside in the rain

Ur gonna need a wiring diagram. The kill wire should Down to your coil. Figure out which one it is and pull it out...if the bike runs, it's your kill switch. If not, it's something with the cdi..either the box or sensor.

Re: Moped has no spark after being outside in the rain

Yeah I followed the kill switch wire down and unplugged it, but still no spark so I guess that switch isn't the issue.

Re: Moped has no spark after being outside in the rain

Brad William /

You're it's first love. You left her out in the rain. The spark is gone. This will take some real work dude.

Just smoove on some new wax, some armorall, pick a serious track for the mood, and admit...

"I fucked up honey"

She'll come around. (edited)

Re: Moped has no spark after being outside in the rain

, continuity 0r n0t

on cb radio band,, the skip has been rollin !

and everybody is talkin ! ,, ya,, under pressure !

barometric , I think that's what it's called,, & its flooding in California ! haahaahaa !

hobbit2.JPG

Re: Moped has no spark after being outside in the rain

Brad William /

Shit, someone is drunker than I am at quarter to two on a Monday.

Re: Moped has no spark after being outside in the rain

Brad William /

It's all smiless from wherever it comes though:)) (edited)

Re: Moped has no spark after being outside in the rain

Any more ideas? Is it possible that little black box with the spark plug wire coming out of it is damaged from the rain? Should I purchase a new one?

Re: Moped has no spark after being outside in the rain

YA, Check that wire, or and also where it comes from. maybe set the bike in the sun , open air * for awhile.

no problems,, only solutions !

good luck !

Re: Moped has no spark after being outside in the rain

Anybody know how to test the ignition coil on my tomos with a multimeter? I can't seem to figure out why I don't have spark!

Re: Moped has no spark after being outside in the rain

Probe the link at the top of REPAIR page. It worked for me.,,

Adjusting my squash . on my thing now !

zuch.JPG

Re: Moped has no spark after being outside in the rain

Here is a short video of the stock wiring and how I bypassed the kill switch to rule that out as the problem. Let me know if I didn't bypass it correctly for if you see any red flags in the wiring.

Re: Moped has no spark after being outside in the rain

from memory, white black trigger go to white blk on cdi. kill switch split wires connects to the stator power coil wire red cdi. tighten up all connections, clean grounds, tighten spark plug cap/wire , but first remove rubber gloves.

Re: Moped has no spark after being outside in the rain

I wonder why this bike, which I purchased new, has the split wire between the white wire from the trigger and the white wire on cdi box..

Re: Moped has no spark after being outside in the rain

Dirty30 Dillon /

There are FACTORY issues with these CDI's failing. This is a known problem.

My suggestion is to approach the shop you bought it from for a replacement, or buy one yourself and replace the stator.

Re: Moped has no spark after being outside in the rain

Hey Dillon thanks for the reply!

I have a new cdi / ignition coil on the way!

Which stator do you recommend I purchase? The same one that came stock? Can you provide a link to the one I should get?

Thank you so much for helping!

Re: Moped has no spark after being outside in the rain

Dirty30 Dillon /

> Leo Mon Wrote:

> -------------------------------------------------------

> Hey Dillon thanks for the reply!

>

> I have a new cdi / ignition coil on the way!

>

> Which stator do you recommend I purchase? The same one that came stock?

> Can you provide a link to the one I should get?

>

> Thank you so much for helping!

Just buy a stock CDI and it will bolt right on. I suggest contacting the dudes over at doscycles.com , I know they have them in stock and they'll get to you fast.

Re: Moped has no spark after being outside in the rain

♣Slew Foot♣ /

Okay that first black wire you pointed out the one that split into two you're on the black wire from the Magneto right into it leaving the kill switch part off the black wire is the signal and it gets interrupted by the Killswitch so the Killswitch may still be the culprit if you took both those wires off it wouldn't start

Re: Moped has no spark after being outside in the rain

I finally fixed it. It was the cdi ignition coil that pooped out. Ordered a new one a few days back and installed it just now on my lunch break. Moped is running great now! Thanks for all the suggestions!

Re: Moped has no spark after being outside in the rain

right on Gr00vie , good work !

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account