??? Tomos help

Okay guys got my 2010 Sprint running again, the kill switch working, horn working, taillight/brake light...But now the headlight won't work unless grounded (obviously), but when I ground it, it kills the engine as well?!?!??! I am a NEWB make fun of me but I appreciate all the help and tips, you guys are my only Moped friends :) and any suggestions would be appreciated.(edited)

Re: ??? Tomos help

kevin Smellaflange /

wiki...get a wiring diagram for your model...a good soldering iron & flux & solder...

and put the sherlock hemlock eye on the inside of your headlight bucket...

it's probably got someones ''elec. tape'' all over it.

Re: ??? Tomos help

Sadly this particular bike has been simplified slightly, and rewired by the previous owner.

Re: ??? Tomos help

kevin Smellaflange /

then everything i said is more important...

research the correct way to wire it & see if you can't make some logical sense of the newly acquired mess.

if u already had it started..then @ least u know it runs.

take phone pics to get to where u need to be if u try something that doesn't work out..

do all of these things to understand your bike better...then & only then is it really your bike.

Re: ??? Tomos help

kevin Smellaflange /

make sure u aren't your bikes worst enemy , by screwing w/it.

maintenance & modding it are left for people who know what will work or have more than 1 ride & can just take the other bike if they can't keep their hands off their new one, or always have to fiddle w/something.

if it runs, maintain it properly & leave it alone.

Re: ??? Tomos help

Yeah, I have learned a GREAT deal from everyone here and from researching. I really feel like I have a crossed wire somewhere in the headlight that's causing this issue.

Re: ??? Tomos help

I totally agree!! :-) I don't mess with things that are working fine :) The last thing I want to do is cause myself a problem lol!

Re: ??? Tomos help

kevin Smellaflange /

do u have a good set of tools?

Re: ??? Tomos help

Yes sir :-)

Re: ??? Tomos help

just make sure your power to the head light is connected to your regulator. bypass the switch and just run with it on all the time. straight to high beam.

Re: ??? Tomos help

Interesting...I'll have to take a look at that tomorrow! Thanks for all the tips and help everybody!! :-) :-) :-)

Re: ??? Tomos help

You got some kinda ground issue. Follow the kill switch wires, one comes from the ignition, the other grounds out. Somewhere the ground connects with headlight ground. It probably shouldn’t.

Or another option is that you have been running your headlights off the ignition coil and turning it on basically acts as a kill switch

Just my two cents

Re: ??? Tomos help

Yeah I think you're right on! I am going to get back at it tomorrow morning! I honestly, after looking it all over and after sitting thinking about it for a while, think that I made a wiring mistake in the headlight. I'll update tomorrow thanks everyone again for all the tips and information!!!!! :-) :-) :-) :-) :-)(edited)

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account