1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

I got the carb installed today, and it starts and runs with one kick. It starts with choke, and only runs with choke. It came with the stock jet i was told it was a 53 but I really have no idea what it is. would jet size be the culprit or air leaks?

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

i read a guide that said the guy used a 64 jet. and it ran fine. If its running a mid 50s jet does that mean its running lean, and the choke is making the mixture closer to normal? it seems to bog when i take the choke off and pull the throttle. It wont idle without choke no mater where i move that idle adjust screw. Seems lean to me but im not an expert.

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

(1)You have an air filter on there? Makes a big difference.

(2) A #53 jet should be fine on a stock 50cc.

(3)Do you have reed valves?

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

yeah i got the stock reed valve on. i have an air filter on it, one of the high flow k and n types.

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

So you probably have an air inleakage. Base gasket,loose intake or carb to intake or hopefully not weak crank seals.

A dirty main jet or carb passages will also cause this condition. Clean that carb for sure.

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

the carb is brand new, so i dont think that the issue. i installed new base and head and exhaust gaskets. i checked the piston and cylinder and they seem a bit rough. signs of blowback.

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

There are no guarantees with clones .

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

kevin Smellaflange /

did the clone merchant give a good shipping time?

i was thinking about a del clone but...all of the clone-keepers seem sketchy...who did you use?

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

yeah, only a few days, a guy off ebay, look for runtong clone sha 1515 somthing like that. i think he's on this site btw. im going to start micro drilling the jet to see if it helps.

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

Jack Rutherford /

you need mid to high 60s jet. make sure your slide is going all the way down. you may have to adjust your throttle cable in order to do so.

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

Jack Rutherford /

You probably have an air leak where carb connects to intake adapter or at chamber cap.

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

ok, i drilled out the jet one size with micro drill bits and it is now idling without choke, but the throttle response is laggy, ill pull the throttle it will bog, then rev up, when im off the thottle, it will take a while for it to rev down. any suggestions, should i drill it up another jet size?

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

> N R Wrote:

> -------------------------------------------------------

> ok, i drilled out the jet one size with micro drill bits and it is now

> idling without choke, but the throttle response is laggy, ill pull the

> throttle it will bog, then rev up, when im off the thottle, it will take

> a while for it to rev down. any suggestions, should i drill it up

> another jet size?

Sounds too much like an air leak .

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

how would i diagnose where its coming from?

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

can air come in through the throttle cable if its cracked?

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

FIXED, i found it, massive air leak. i took off the auto choke and forgot plug one of the holes in the intake

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

Jack Rutherford /

Cool (edited)

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

Good you got it sussed . ;)

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

Jack Rutherford /

any little bit of crud in your main jet will cause similar symptoms on SHA carb

Re: 1981 nc50 with SHA carb clone - RUNNING!!! but only with choke.

I am sorta having the same issue, how did you plug the hole for your intake?

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account