Is this bad??

Bought this Tomos A35 had mods on it pretty beat up ran but shitty would bog and hesitate and four stroke at least it seemed all at once. Would occasionally fall into place and run up to 45mph but struggle on the way. So I got a new carb vm20. Intake, reeds, alukit, gaskets etc. throwing these parts at it thinking one would eventually get it right, it pretty much is doing the same thing. I also swapped a coil off another good running tomos to see and no change. So figured I’d look at the ignition. I was getting spark and the thing would run like shit, but can this damaged coil be my problem maybe? At this point I’m ready to just replace it with a new magneto and parmakit combo would that be an upgrade to this? Help please

18548818-E65E-4E21-A251-623E6ACFF070.jpeg
A380CB40-6572-4693-8A28-50D171CBD265.jpeg

Re: Is this bad??

Brandon Weiss (Detective brandon to you) /

I can't tell which of those is the lighting coil. If the damaged one is the lighting coil, then it shouldn't affect the way the bike runs. I think it probably is, as i doubt it would run at all if that were the coil for the ignition.

In any case, i would replace it with a new one, the parmakit set is a good option.

Did you replace the crankshaft seals?

Re: Is this bad??

Dirty30 Dillon /

Yeah, that's super fucked. What's probably more fucked is that you didn't check the ignition before ordering all sorts of parts to throw at it.

The lighting coil ground to the case via contact with the flywheel will definitely fuck up ignition, especially with a CDI.

Re: Is this bad??

Brandon Weiss (Detective brandon to you) /

Guess i was wrong, listen to this man^^^^^^^^^^

Re: Is this bad??

No I didn’t change the seals. Didn’t seam to be leaking though.

Would this kit be a good choice as a replacement?

https://www.treatland.tv/tomos-A3-A35-and-A55-complete-OEM-cdi-plus-many-f-p/tomos-cdi-rehab-performance.htm

Re: Is this bad??

Brandon Weiss (Detective brandon to you) /

> Mj Sizemore Wrote:

> -------------------------------------------------------

> No I didn’t change the seals. Didn’t seam to be leaking though.

>

> Would this kit be a good choice as a replacement?

>

> https://www.treatland.tv/tomos-A3-A35-and-A55-complete-OEM-cdi-plus-many-f-p/tomos-cdi-rehab-performance.htm

Yes, that's a great choice. I'm waiting on the propack version to show up at my door.

Re: Is this bad??

change yr seals, all that oil from gas mix behind stator.

Re: Is this bad??

despite the lighting coil being wrecked, the ign coil has some shit taken off it too, easily could ground out sporadically.

so is it fucked? yes, duh. obviously. perhaps a better question is WTF happened? like what was in ther e grinding away?

Re: Is this bad??

I don’t know what caused it. I don’t see any missing screws. Would that kit I posted a link to above be my best option? On a properly functioning engine would it be a upgrade with the ignition curve? Will I have to set the timing ?

Re: Is this bad??

Dirty30 Dillon /

> Mj Sizemore Wrote:

> -------------------------------------------------------

> I don’t know what caused it. I don’t see any missing screws.

Definitely more than a screw.

> Would that kit I posted a link to above be my best option? On a properly

> functioning engine would it be a upgrade with the ignition curve? Will I

> have to set the timing ?

Curved ignition is always an improvement, and yes you will have to set your timing no matter what ignition you put on there

Re: Is this bad??

Yeah dude I bought it from was running it without a flywheel cover. Maybe a rock. Am I going to need a timing light to get it right? I never set timing before

Re: Is this bad??

Replace your crank seals. Fix the insulation on the top coil with a little epoxy, it doesn't look bad so it's probably ok. The bottom coil is junk, so you'll want to find a new coil. The little one behind it is probably ok though. It looks like someone used something to try to hold the flywheel to get the nut off and wrecked the coil in the process.

Re: Is this bad??

Bad Cadillac™ /

Dude, that coil is not the issue to all your problems you listed above in your first post.

You got a lot going on with this bike including that coil.

Re: Is this bad??

Yeah definitely been a project to say the least. Since my last post I discovered my crankshaft taper where the magneto sits was severely chewed up I’m assuming from electrolysis or bad connection. So got a new one on the way along with new bearings and seals, a55 ignition w/ Parma coil. If I can get it all installed tight with no leaks I’m hoping it will be right. Have a tranny issue aswell to top things off. Think it was a shot one way needlebearing in the clutch assembly, plus a missing sprag wire clip. Relinning my 2nd gear clutch also. It never ends lol.

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account