Moped isssue please help

Robin Benecke /

So i have a gy6 and it starts and runs for roughly 30 seconds then shuts off. Have to wait a few mins then it'll start up again. Normally a carb issue however I pit a good carb off my Good running moped and still doing it. What can it be?

Re: Moped isssue please help

Moped Lar (OFMC) /

It be a scooter. Try a gy6 scooter forum.This is a vintage 2 stroke, pedal assist, moped forum.

Re: Moped isssue please help

Lar's right, but if you're still following this I can try to help. a lot of us despite a healthy disdain for scooters, especially cheap china GY6's, also have a decent knowledge of them anyway

my very strong suspicion is fuel flow. check that it' flowing smoothly. the fuel flow needs a vacuum line to the petcock on the bottom of the tank, that line connects to a bung/nipple on the intake, between carb and head. removing this line and sucking on it should let fuel flow (don't worry, it's a separate line and only for vacuum - it allows fuel to flow onl when bike's riunning, but that vac line never has gas so you wont get any in your mouth.) you can also unscrew the drain bolt on the hose coming outt he bottom of the carb, that'll let you directly view and visualize the gas flow.

anther likely issue is clogged carb (or big airleak which would remain even after swapping carb - perhaps around intake, or the vacuum hose ine on the intake cracked, loose or missing.) coupled with not disengaging auto-choke - check for autochoke videos on youtube.

could also just be bad gas or water in there that's dispacing fuel

and finally, if all else fails, check valves.

Re: Moped isssue please help

It could a clogged gas cap vent. Try running the engine with the cap removed.

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account