1986 Motomarina Sebring No Spark

Joel Baldwin /

Can anyone clue me in to what might be the problem with my 1986 Motomarina Sebring? It was flooded during Hurricane Sandy and I'm trying to get it running again. When I crank it it has no spark except, when cranking it, I shut the kill switch off and then back on which gives me one spark. If I keep hitting the switch on and off while cranking it I get a spark every time but only one for each time I switch it to the on position. It's got the Morini M1 engine. Any help would be appreciated.

Re: 1986 Motomarina Sebring No Spark

Moped Lar (OFMC) /

Have you tried cleaning the points?

Re: 1986 Motomarina Sebring No Spark

Pull the grey ground wire that attatches to the frame(single designated wire) and let it hang there without touching anything...kill switch kills motor by making connection (ground)to the frame so...there ya go.

Try again and see if you get consistent spark.

And then check your points...was the motor submerged?

Re: 1986 Motomarina Sebring No Spark

Also,unhook the horn.They have been known to rob spark somehow.Make sure the kill switch isn't grounding a little too.

Those bikes will also lose spark every time you squeeze the brake if a brake light blows,so make sure your brake bulb is good and the terminals are good back there. don-ohio (:^)

Re: 1986 Motomarina Sebring No Spark

Joel Baldwin /

I did clean the points and tested them with a multimeter and they appeared to be functioning fine.

Re: 1986 Motomarina Sebring No Spark

Joel Baldwin /

I tried disconnecting the red wire to the kill switch but I'll try disconnecting the ground to see if that works. The points appeared fine after I cleaned them. The motor was completely submerged thanks to Hurricane Sandy.

Re: 1986 Motomarina Sebring No Spark

Joel Baldwin /

When I crank it both the headlight and the tail light works. Fortunately, the water did not get high enough to get to the tail light even though the motor was completely submerged. The kill switch looks like it's grounded whether it's on or off according to the volt-ohm meter. I'm going to try Dan Ott's suggestion of pulling the grey wires to see if that makes any difference tomorrow. Thank you.

Re: 1986 Motomarina Sebring No Spark

I'll buy your bike

Re: 1986 Motomarina Sebring No Spark

Overpriced Parts /

Switch/contacts bad

Re: 1986 Motomarina Sebring No Spark

Joel Baldwin /

I thought that might be but when I disconnected the red wire the switch opened and closed okay through the multimeter.

Re: 1986 Motomarina Sebring No Spark

Joel Baldwin /

I bought this moped new in 1986 and have owned it for 28 years. It ran flawlessly before the storm but was submerged in salt water unfortunately. I'd like to try to get it going again for sentimental reasons and I'm not sure you'd want it if you took a close look at it. Even if I get it running again it needs things like shocks. Hopefully the engine is okay but I'm not sure unless I can get it running. I'll keep you in mind if you're still interested.

Re: 1986 Motomarina Sebring No Spark

Pull the three wire connector from the stator (red/black/green) apart..jump the red to the stator...ground the black to the motor and let the green hang.

Pull the spark plug and tape it to the cylinder so the spark can jump to the fins(1-2mm).

Hop on it and start peddling..watch for spark...you would like to see a strong blue arc.

If you have spark..put the plug back in and try again...should fire up...go from there

If it doesn't the primary ignition coil could be fucked but then again your headlight came on

Re: 1986 Motomarina Sebring No Spark

Joel Baldwin /

I'll give it a try and let you know. Thank you.

Re: 1986 Motomarina Sebring No Spark

Joel Baldwin /

Did everything you suggested and got nothing. Checked the red and black side with a volt meter and got something like 4 volts AC. The green and black side gave me about 13 volts AC. And as I said earlier, I can get a spark if while I'm cranking I toggle the run/kill switch on and off but I only get one spark for each time I switch it to "run".

Re: 1986 Motomarina Sebring No Spark

Check coil/stator ground .

Re: 1986 Motomarina Sebring No Spark

Last time mine sat in heavy rain the water got into the flywheel and corroded the coils. I tried the lazy method and sprayed it with wd40 and it fired right up. It has a moisture repelling effect. Next time I need to pull the flywheel I'll clean it up good but has run great since

Re: 1986 Motomarina Sebring No Spark

Joel Baldwin /

I ended up using an entire can of WD40 on it so far and a half-gallon of Marvels Mystery Oil. Unfortunately, it was submerged in salt water, which is wreaking havoc on everything so far. The engine was rusted-seized but I got that going. I still can't get a consistent spark. I already removed the flywheel and cleaned what I could see. I'm going to remove the flywheel again and check the grounds again soon.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account