No spark after transporting moped.

Puch Magnum II, za50, hardwired headlight & horn circuit.

Not entirely sure what's up here - short of re-wiring completely, I've done every check imaginable. Checked, replaced plug, replaced plug wire/boot, checked coil continuity, pulled stator, checked killswitch, checked grounds.... still no spark. I'm getting lights, so it's not the system ground. Just straight up nothing from the plug. I'm thinking i'll go through the wiring and re-do it completely for shits n giggles, but before that, anything I've possibly overlooked? Still a bit of a noob about this, but I'm thoroughly stumped. Any thoughts?

Re: No spark after transporting moped.

♣Slew Foot♣ /

main ground on ht coil terminal #15 unhooked or loose, condensor. horn bypass fail. killswitch grounding or bared somewhere in the wiring, brake leeds touching, resistor in headlight compartment fried/terminal grounding.

headlight works, so does the tail? is the brake light always brite? oily pointset?

after that i would run a 9v neg to frame, positive to the signal in terminal and strike it a few times while checking for spark, it should fire if the ht coil is still good.

Re: No spark after transporting moped.

Will try all that n more. I daren't say it yet, but you just might be a wizard. Will report back after work today. Thanks, dude!

Re: No spark after transporting moped.

Overpriced Parts /

Hardwiring is complete wrong. Wire the correct way with full wiring harness, utilizing all six wires of the stator, all grounding wires and grounding points for reliable starting and running .

All the coils, wires and all the grounds are there for a reason. If you don't use them you will not have a reliable safe operating bike not to mention Dim or no lights at idle/non regulating lighting system.

Full factory wiring is needed for the lights to be self regulated.

If you want you can email me I can take off the cover of my magnum ll and email you a picture of the stock wiring block if you need to see how it's done correctly.

Re: No spark after transporting moped.

Any recommendations for a non-stock setup, however? I just pm'd ya, i'd still like to see the example as for something to work with. i'm not buying a whole new wiring harness - rewiring from the ground up. As I don't have the original coils anymore, nor the taillight assembly, speedo, horn, etc, I'm looking for the most efficient system for these electrics:

Head/Tail coil, treats 12v.------> tail: semi truck indicator light. headlight: 12v 32w halogen bulb

stock brake-light coil, 6v, ------>nothing yet

stock ignition stator coil

stock ignition external coil

Currently, horn circuit is grounded to stator ground. Killswitch is attached to ground and to coil connection.

That's all i've got for electrics. Will be buying a small 6v light to use as brake light. I'm workin with what I got. (edited)

Re: No spark after transporting moped.

Tried the 9v trick- looks like my coil is still good. Pulled kill switch out of rotation. Fresh wire throughout. Gonna pull, check stator, points, etc. already sanded and cleaned, gapped points. Maybe bad internal coil or connexion? Very nonplussed.

Re: No spark after transporting moped.

I have a circuit continuity tester. How would you test the ignition and points system to see what is the trouble? Disconnecting all leads- I'm pretty sure my wiring is good. Everything works except for spark, and my points are clean, adjusted according to how they have always functioned.

Re: No spark after transporting moped.

if your tester is the 12v light bulb style, not led / powerprobe, you can test the stator output to the HT coil.

disconnect the wire from the stator to the coil, and hook it to the tester, attach the clip to the motor, cranking, it >may< flash.

my single best test is ohming the points to ground, needs to be 0 resistance closed, anything more is unacceptable. (edited)

Re: No spark after transporting moped.

Hey, guys - it lives! Worked on it last night, eliminated possibilities by checking each segment of the ignition circuit, got it down to the points. Pulled the stator, everything looked fine, but after continuity checking the points (which were still creating a circuit at open) I realized that the condenser lead that comes off the points was slightly touching my new 12v coil. Not sure how it happened, but I resituated the wires and the points broke circuit! Reinstalled everything, put the cap back on, and turned it over. Bingo! She runs!

Thanks again - that 9v bulb trick is fuckin nifty. You guys were super helpful, kept me checkin my facts.

Now, we must make it faster.

Re: No spark after transporting moped.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account