2005 Streetmate. NO SPARK

Shawn Martin /

I made another post several weeks ago about this thing dying but it wasn't accurate and I just want to start over with what Ive found and more detailed info.

I have fuel and new spark plug. But when I connect the plug to the plug wire and touch it to the engine I get zero spark 95% of the time when kicking the pedal. Every once in a great while I might a get a very weak one. I have this hot wired since I lost the key 2 years ago and it has ran great the whole time.

How I have it hot wired goes like this... I disconnected the white connectors inside the storage compartment that goes to the key/ignition and put a cutoff paper clip inside the other connector bridging the PINK and YELLOW wire. So I rechecked the connection and wiggled the clip, removed, reinserted it. No luck. Should I just completely cut that connector off and tie the pink and yellow? I'm good with car engines but I have little experience with electrical stuff on this moped. Where should I go from here? What to check, what to do? I don't want to haul this to a motorcycle repair shop

Re: 2005 Streetmate. NO SPARK

Shawn Martin /

Don't know if this matters for wiring purposes (grounds, fuse) but the brake light, turn signals, headlight, all work. (edited)

Re: 2005 Streetmate. NO SPARK

Shawn Martin /

Tried to do some research so I'm going check the resistance from the plug wire. And disconnect the kill switch to see if its grounding out the CDI.

But any help would be great. (edited)

Re: 2005 Streetmate. NO SPARK

Shawn Martin /

I'm not making progress and getting frustrated. At this point I have a 45 mph Streetmate that I'm about to completely tear apart down to the nut and bolts and sell it piece by piece. So if I don't get any response in the nest couple of days.. Look for parts!

Re: 2005 Streetmate. NO SPARK

Sell it to me! HaHaaa! So you know the CDI is good? don-ohio

Re: 2005 Streetmate. NO SPARK

Shawn Martin /

No.. thats why I need help. I don't know the correct way to check it.

Re: 2005 Streetmate. NO SPARK

I carry an extra one in my toolbag,but I've never needed it. I just figured,`Why not have one and also an extra voltage reg.'

I probably would buy another one for future use if I were you,and that way you could plug her in to test.

There MAY be someone on here that knows how to test one.Sorry that I don't.

Hope you get her running good again. don-ohio (:^)

Re: 2005 Streetmate. NO SPARK

Shawn Martin /

Wheres the least expensive place to buy one? 1977 has one for $32

Re: 2005 Streetmate. NO SPARK

I had a customers early streetmate come in, it had a faulty coil in the stator. Had to replace the 4 coil stator unit since they are not easily removable. It came in with no spark, then started working for no real reason, then shorted out again and would only spark intermittently. I tried changing the pickup, and the cdi/ignition coil with known good ones, and it was not the fix. If you want a new CDI I have a few OEM Tomos ones and maybe a good used one. PM me.

Re: 2005 Streetmate. NO SPARK

By the way Shawn, to answer your question, the best way to check for spark on a streetmate is to find the wires coming out of the case. Should be 5 coming out. Find the 14ga red wire that runs into a thin 18 ga black wire. Unhook it there. Then follow the black wire toward the CDI/Ignition coil and you will see a red wire coming from there hooked to the other end of the black wire. Direct connect the red wire to the red wire, and you have circumvented all the switches on your bike, including the key switch. I'm pretty sure your electric start won't work like this, but kicking or pedaling should still cause the spark to go.

Myrons Mopeds has the best wiring diagrams.

Re: 2005 Streetmate. NO SPARK

I'd check with Myron'sMopeds,since they have made wiring diagrams available for the StreetMate.

I bought mine years ago from Ike Fist(R.I.P.),the best dealer,along with ChrisMWH,and BJ at Handy Bikes that I've ever dealt with.

I'm sure Treats and Myrons and most others are great too.

32 dollar is cheap for a CDI unit. don-ohio (:^)

Re: 2005 Streetmate. NO SPARK

Shawn Martin /

Thanks Jon I will connect the red wires and post back. If it sparks then its a switch problem of some kind?

Re: 2005 Streetmate. NO SPARK

Shawn Martin /

Alright. Finally had time to tinker. I connected the two red wires together to bypass everything and I got a great spark! Runs good. So now whats the deal? What would be the most logical problem? Faulty kill switch? etc?

Thanks for getting me headed in the right direction.

Re: 2005 Streetmate. NO SPARK

Yes, if you unhook the reds and put the switch back in the equation, it is grounding out somewhere. Put a continuity tester on the black wire while and the other side on the frame. When the switch is in the "on" position, there should not be any continuity, and when it is "off" it should have a good connection to the frame ground. If it is not this way, visually inspect the wires all the way to the switch and see where the wire is grounding. My guess is probably near the headtube of the forks, the streetmate fork stop isn't quite wide enough so it's possible for wires to get pinched inbetween the forks and the frame.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account