oil feed pipe.

So I took off the oil injection in my streetmate r. But after a while it started to annoy me so I'm going back to oil injection. Everything works perfect but I'm not sure If the oil feed pipe is acctually putting out oil. I've been running it both with mix and the oil injection and it's not running lean. So I took off the nipple and tried to blow through it with little success. Should it be easy to blow through or what?

Re: oil feed pipe.

How often should it be putting out a drop of oil?

Re: oil feed pipe.

You should run premix in the tank, bleed the oil pump and then run it until you can see that oil is flowing through the hose.

Re: oil feed pipe.

The oil is flowing through the hose and the pump is working. I'm just not sure about the pipe that puts the oil into the carb? How many drops of oil should come out in say.... a minute? What should my dpm (drops per minute) be?

Re: oil feed pipe.

Well,that's hard to say,Josh. Drops= teaspoons which =Tablespoons which 2 of those equal one OZ.,correct? Drops are all different sizes also,so you can't say so many drops.

Here's what I did.................(1)Fill your gas tank and your OIL INJECTION tank to the brim.

(2) Run the bike for a coupla gallons of gas and see EXACTLY how many ounces of oil it takes to fill the oil injection tank back up to the brim.If it takes,say 7 oz.,that means it's injecting 3.5 oz. of oil per gallon,roughly a ratio of 35:1,which is great!

But when I checked my Streetmate's it was only injecting at 62:1.I keep mine hooked up,but premix 1.5 to 2 oz. of oil per gallon also. don-ohio (:^)

Re: oil feed pipe.

Thanks! That was genuinely helpful! I'm going to try it.

Re: oil feed pipe.

So now.... I'm riding It and it sounded like I hit the cutoff switch. ... but I didn't it came to a slow stop and I have to pedal it all the way back home... like 2 miles... any tips?

Re: oil feed pipe.

Wow! Probably dead spark plug. Always carry a spare.Maybe your petcock is clogged.Have you pulled the bowl off yet? Checked for spark? don-ohio (:^)

Re: oil feed pipe.

There is gass in the line and the engine tries to start but it seems to be bogged down by throttle.

Re: oil feed pipe.

Got it started it.. I'm home now... it was really sluggish and sounded like it was almost missfiring. I'm going to change the sparkplug now. And see if it makes a difference.

Yeah... I must've been running quite rich...

20140826_122808.jpg

Re: oil feed pipe.

Yeah,get that plug replaced,and when you are checking the way I said,you need to allow that the injection IS working,so you only premix 2 oz. of oil per gal. when you add gas. don-ohio (:^)

Re: oil feed pipe.

Dirty30 Dillon /

From the sounds of it, you should probably drop the exhaust and make sure you didn't cook the topend be improperly bleeding the system/fussing with it.

Re: oil feed pipe.

Well... I got it running. Drive about 5 miles.. and it happened again... this is killing me... and my pedals are falling off..

Re: oil feed pipe.

So... once again I got it started after about 10 minutes of pedaling...

This is what the sparks plug looks like... ??? I don't know what it is... it is almost like something keeps hitting the kill switch! ! But than after a couple minutes of pedaling it starts right up??? Anyone???

Re: oil feed pipe.

This is the sparkplug after 2nd incident

20140826_141311.jpg

Re: oil feed pipe.

Could it be my fuel filter... before all these problems started happening I changed the fuel filter b/C the old one was leaking.. I could only get a giant universal fuel filter from the hardware store. Could that be the issue?

Re: oil feed pipe.

Both your plug pics looked fouled to me. Ditching the oil injector and premixing your gas for a more precise oil/gas ratio will be the best way to cure this if it was working fine with the injector off. Fuel filter is likely not an issue.

Re: oil feed pipe.

But it starts and runs fine? With the second spark plug? I'm thinking the fuel filter is too big for the fuel lines. So it empties and then it needs to be filled back up. Ie that 10 minute period..

Re: oil feed pipe.

Did you remove that petcock yet? They're easy to plug up and also that gas cap has to vent.don-ohio

Re: oil feed pipe.

As wet as the 2nd plug is, I doubt fuel flow is the issue. If it was running out of gas the plug would be dry.

Re: oil feed pipe.

Where do you see the plug is wet,Ryan? First pic shows oil fouling....second pic looks dry to me. don-ohio (:^)

Re: oil feed pipe.

Try running without gas cap, vent issue?

Re: oil feed pipe.

Don Ruggles Wrote:

-------------------------------------------------------

> Where do you see the plug is wet,Ryan? First pic

> shows oil fouling....second pic looks dry to me.

> don-ohio (:^)

Oily residue left on plug surface and threads in pic 2. He isn't running out of fuel or that wouldn't be present... very wet and very dark. It looks not nearly as bad as pic 1, but I wouldn't call that optimal.

Oil injector is the only change made? If it isn't fuel delivery it could be a condenser going bad.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account