77 mopeds hobbit cdi issue

I have a hobbit with 77's cdi kit installed. The bike used to start, but it won't spark now. All the grounds are solid and I have tested continuity of all the wires. Everything looks good on that front. I spun the magneto with a drill to test the voltage coming off of all the stator wires. The wire that supplies power to the cdi box isn't showing any voltage. Any ideas? Please note that the magneto really seems to grind on the metal part of the coil mounts. Thanks.

Re: 77 mopeds hobbit cdi issue

When I got line the cdi stator coil was shorted to ground where it comes off the coil.

Remove the ground of the coil from the stator plate and check its continuity to ground, it should no longer have any (be sure the cdi is disconnected). If it still shows continuity you have a short.

Your flywheel should never touch the stator when turning.

Re: 77 mopeds hobbit cdi issue

The coil used to work, but maybe a short developed. Non of my other bikes ever had a magneto that rubbed the coil. I thought that might be an issue but I needed an extra head on this one.

Re: 77 mopeds hobbit cdi issue

Emil Kniemel /

are you using the stock ignition coil or the one that came with the CDI? im referring to the thing that sparkplug wire comes from/attached to

Re: 77 mopeds hobbit cdi issue

Using the ignition coil that came with the cdi. That shouldn't have anything to do with the fact that I'm not getting voltage from one of my stator coils.

Re: 77 mopeds hobbit cdi issue

Any volts from stator coil, one for lights?

Re: 77 mopeds hobbit cdi issue

I'm getting volts from everything but cdi power.

Re: 77 mopeds hobbit cdi issue

From Stator coil to box or not from box?

Re: 77 mopeds hobbit cdi issue

Yes. Coil to box has no juice.

Re: 77 mopeds hobbit cdi issue

Then you have a short or an open in the coil. There is no other way around it, not even suggesting that the magnets have no pull because your other coils have output. You have narrowed it down yourself just fine, why is this thread still full of speculation?

Re: 77 mopeds hobbit cdi issue

Is there a way to fix the short or open coil? This is new territory for me.

Re: 77 mopeds hobbit cdi issue

Well it looks like when it rubbed on flywheel it wiped the coil out putting a new coil won't work until you fix where it was rubbing. How did you get fly wheel off , you might have bent it.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account