Tomos A3 no spark (points ignition)

Lungz ~~~ /
This single post is part of a larger thread. Start from the top or view this post in context.

I'm having trouble with my 1986 tomos A3, it's day 2 and I've spent hours trying to trouble shoot this. I'm using this wiring diagram because it's basically exactly like mine:

I'm using an OEM CEV coil so the tail lights and magneto ground are tied to the side screw. I should also mention I had the moped in "RUN" and did check that the connections on the switches were good and clean. I have a new spark plug and cap. I'm pretty sure I set the points within reasonable accuracy (enough to get spark I would imagine).

- There is a new condenser, new points and new coil for the ignition. I've tested all these and they are soldered properly and working, no spark

- I know this model has particular trouble with the tail lights causing shorts and the no spark problem, but I tested the rear bulbs and they're ok. No spark

- I grounded the blue wire that comes out of the magneto and leads to the tail lights, still no spark

- I also grounded the brown and grey/green wires that lead from the break buttons to the tail lights, nothing yet again

So first of all, does it look like I've attached things properly (from what you can see at least) and is the coil set up properly?

Second, am I grounding the suspicious tail light wires properly? I tried only grounding the brown wire and connecting the three grey wires together and also just grounding all of them

Third is there something obvious that I missed? I've been doing this so long that I probably missed something and would love a 2nd set of eyes.

Any advice would be awesome!

This single post is part of a larger thread. Start from the top or view this post in context.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account