qt50 cdi blowing

matt boda1nz /

anyone know why a cdi would blow on a qt50?

there is no headlight and no tail light on this beast, but, there is a battery. i connected a voltage reg. to the lighting/battery line after i blew the first cdi...

looking at the schematic, the cdi is connected to a totally differen't coil than the battery charge/lighting coil.. so it baffles me.

my buddies blew when no battery and light were connected.. so weird.

Re: qt50 cdi blowing

matt boda1nz /

when he hooked up the battery and lights, everything was fine, after a new cdi was installed.

i burned through 2 cdi's i had laying around already, so now i am going to get the lights up and going.. sheesh (edited)

Re: qt50 cdi blowing

bad connection on coils ??? Have ran several with out battery and head light with no problem very strange. Did the 2nd CDI blow with the regulator in?

Re: qt50 cdi blowing

matt boda1nz /

I'm going to have another look at the entire electrical side of the ignition system.. will report back. It may be the charge coil for the ignition. Going to troubleshoot the wiring too.. may be a day or two.. but yeah, sounds like it's on that side of things.

Didn't you mention something about faulty coils or something?

Regulator was hooked up when the second blew.

Re: qt50 cdi blowing

What color is the coil?

Re: qt50 cdi blowing

matt boda1nz /

White I think???

Re: qt50 cdi blowing

matt boda1nz /

The magneto charge coil is wrapped in like a white gause. This is a 1980 model (edited)

Re: qt50 cdi blowing

I had a lot of trouble with my cdi too when I built my first qt. Its hard to find the info again but I'm pretty positive that white coils are the early ones before they switched to the brown coils around your year model. The early ones were faulty. Once the bike had been heat cycled a few times they quit working. I'm 90% sure the white coils are the early ones.

Re: qt50 cdi blowing

matt boda1nz /

That could explain why the bike only had 1000 miles on it.. I will keep you guys updated. I really never checked the coil due to thinking the blown bulbs were causing this. But after carefully examining the circuit, there's no way that could be it.

Re: qt50 cdi blowing

Ya any thing from mid 80s or earlier will have the white junk coil the later ones have have a dark brow or black charge coil. I had two 1980s both between 1000 & 1200 miles on them and both had bad charge coils. You have a junk one.

Re: qt50 cdi blowing

matt boda1nz /

Thanks for the info guys! Can't wait to rock this thing!!!!

Re: qt50 cdi blowing

matt boda1nz /

Everything is checking out ok so far hmmmm.. what about the fact that I am using a bu8h plug and a 5000 ohm resistor boot? These are plugs with no extending nose and are = to a .016 gap.. maybe it's not enough resistance as stock is a 5000 ohm boot with a .028 gap?

Re: qt50 cdi blowing

matt boda1nz /

Also.. the primary coil measures at spec at 1.6 ohm. A new coil I bought last year is way below that at .5 ohm.. weird.

Re: qt50 cdi blowing

Mine would quit when I got the bike warmed up. Then it finally just quit. Bad condenser like symptoms but I've heard some people's just quit without warning. Just wouldn't start one morning.

Re: qt50 cdi blowing

matt boda1nz /

Alright... well, did some more research online and have found a few posts where the charge coil will measure within spec, but will be faulty. So I'm going to pop a known good stator on there and wait for the cdi. In the mean time I will check all connections and get a traditional spark plug shimmed up and ready to go.

Re: qt50 cdi blowing

nice keep us updated

Re: qt50 cdi blowing

matt boda1nz /

Alright.. alright.. well, here it goes..

Took the flywheel off and the key must have been pushed out of the notch when I put the flywheel on. Now i know what not to do... it must have been sitting in the notch with the flat top of the key facing away from me and the flywheel just pushed it back and out of the notch. What a deal

Amazing this thing ran, looks like it was spinning around on there.. no wonder it was changing it's moods. Got it ripping. This thing is super fun.. going to dial it in next week. Need a few more jets.

Re: qt50 cdi blowing

matt boda1nz /

Oh.. and the Bu8h plug must have had a hard time sparking at idle, I switched it out for a properly shimmed up Bp7hs and it cleared the idle right up.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account