1980 pa50II carb/compression issues

so i picked up a pa50II a couple months ago and when i got it it would start right up, the only problem was that it wouldnt idle. didnt bother me too much so i continued to ride it and over time it started to start really hard, it would take a good half mile of peddeling to get it to run, i adjusted the idle and air mixture screws and still had no luck, i took off the carb cleaned it and put it back on, started good for a couple days then started to loose compresion agein when trying to start it, so i bought a brand new carb put it on and it was working amazing for a bout 5 days then the same thing happend, it lossed compression when trying to start it, (keep in mind it has plenty when running). my thoughts is that its leaking air into the carb but i tightend up the carb nicely and dosnt appere to be. any help would be appreciated i just want too ride it agein with out a 15 min work out befor it starts

Re: 1980 pa50II carb/compression issues

I don't think it's a compression issue; I think you're confusing the terminology.

It sounds like your carb is just getting clogged. Do you have an air filter? I was dealing with the same thing. I could barely go ten miles without the idle circuit clogging again. I installed a new air filter element, and it's great now!

Re: 1980 pa50II carb/compression issues

Do you have a fuel filter on it? maybe the scree3ns in the petcock are3 toast letting junk through

Re: 1980 pa50II carb/compression issues

Definitely clean that carb very well...and then again for good measure..make sure you get the idle circuit clean with some wire and such and then clean it again....90% of the time if my Hobbit isnt working right I just have to clean the carb and then its fine

Re: 1980 pa50II carb/compression issues

hey everyone thanks for the help, so far i have taken off the carb agein cleaned it very well, replaced all fuel lines and filters. i notcied that the old filter did indeed have some crap in it so i took off the gas tank and petlock to find that the tank had some small rust particals that were passing though into the carb. i replaced everything and cleaned the carb but its still not wanting to fire up. any ideas?

Re: 1980 pa50II carb/compression issues

Clean it with a guitar string behind the welch.

Re: 1980 pa50II carb/compression issues

[Radium City] kyle k $ /

i would think about lining the tank also and then the problem will disappear if you do it right

Re: 1980 pa50II carb/compression issues

yep, with POR-15.

Re: 1980 pa50II carb/compression issues

ok where is the welch, i have used a small wire to clear the jet and other small holes too, im assuming por-15 is a gas tank liner or rust preventer im planning on putting somthing in there to stop the rust although it dosnt seem to be rusting at all from looking into the tank but its clear it is by the filters

Re: 1980 pa50II carb/compression issues

You just need and air filter

Re: 1980 pa50II carb/compression issues

There is considerable dissent on the idea of por15 instead of just using a weak acid and a ceramic gas filter if you search the forum. I have my tank filled with apple cider vinegar for a week just now. Others warn that the sealant is quirky and can come off. The pa 50 tank has some kind of internal baffle design which will co,placate the even distribution of the sealant.

Re: 1980 pa50II carb/compression issues

i have an air filter

Re: 1980 pa50II carb/compression issues

alex roberts Wrote:

-------------------------------------------------------

> i have an air filter

i just put a new one in and cleaned the carb for the 5th time since friday

Re: 1980 pa50II carb/compression issues

fallout Survivor /

If you do not reline the tank your always going to have a problem.

At least use 2 fine element filters.

And you absolutely need compressed air to clean those carbs.

Re: 1980 pa50II carb/compression issues

alex roberts Wrote:

-------------------------------------------------------

> alex roberts Wrote:

> --------------------------------------------------

> -----

> > i have an air filter

>

>

> i just put a new one in and cleaned the carb for

> the 5th time since friday

but still no luck, i still have to pedel like hell for a good 5 mins before it will start (when it dose its got plenty of poer and idles fine

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account