Tomos targalx died on me help please!!!!

So I was riding my tomos the other day and I noticed it wasn't going as fast as usual. I kept riding it and it started to sputter in and out. Eventually it got worse the bike just died on me while I gave it gas. It would start up but still sputter bad and the minute I give it gas it dies. Could this be my timing?? Please help I need my ped back on the road ASAP

Re: Tomos targalx died on me help please!!!!

Did you by chance, run out of gas?

Re: Tomos targalx died on me help please!!!!

No I'm not an idiot.

Re: Tomos targalx died on me help please!!!!

Replace your spark plug?

Re: Tomos targalx died on me help please!!!!

fallout Survivor /

check spark by pulling it and pedalling with it grounded.

if no visible spark, check plug, and ignition parts..

If spark was good more likely than not fuel system blockage,

Less likely, blown engine (test with compression guage, or guestimate by thumb). (edited)

Re: Tomos targalx died on me help please!!!!

♣Slew Foot♣ /

choke hung up? clogged jet? clogged exhaust?

infamous clogged gas cap vent?

Re: Tomos targalx died on me help please!!!!

I'm actually having this exact same problem with my targa LX. Just sputtered a bit then died.

So far I've cleaned carb...looked fine (also made sure there was gas in it)

Checked for spark...no spark.

Tried a new plug...no spark

Checked wiring and re-taped anything that looked loose...no spark.

Should I just buy a new boot, cable, cdi box and try one of those first?

Could it be a short in the wiring harness?

I'm not that mechanically inclined so talking to me like I'm an idiot is fine.

Re: Tomos targalx died on me help please!!!!

Yes take the boot off and cut a quarter inch or so of wire then screw the boot back on

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account