Honda Hobbit trouble starting after a week

Title says it...

If I don't ride the Hobbit every few days, or let it sit for a week then I have to 'blow out' the bore for the idle screw on a good day.

Most of the time though I must unbolt the carburetor and blow out every crevice. I have a simple briggs mesh filter in the gas line.

It will fire but wont idle or run on its own. Once I clean out the carburetor its fine. I understand the Hobbit carburetor is finicky...but I've seen smaller jets and bores on weedeaters and they dont do this.

Do I need a better filter? What sounds like the problem?

I could live with it at first but now its starting to get old. :l

Re: Honda Hobbit trouble starting after a week

better filter maybe, clean the tank? alternate carb?

Re: Honda Hobbit trouble starting after a week

Just bought a beefier filter for gravity fed fuel lines.

Tank is cleaned and coated with POR 15 gas tank sealer.

Is there any after market carburetor thats a simple bolt on?

Re: Honda Hobbit trouble starting after a week

Better filter for you.

Re: Honda Hobbit trouble starting after a week

did you make sure to clean out the idle circuits behind that screw really well? use a strand of wire...thats what it was for one of my PA carbs

Re: Honda Hobbit trouble starting after a week

Is the carb flooded after sitting? Shut your cock off before leaving it for a week. Dripping cock often?

Re: Honda Hobbit trouble starting after a week

Shut off your pet cock for your last mile and milk it empty before you store

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account