Tomos A3 has spark, won't turn over

I've been posting a lot trying to get this bike running. Good news is I finally have spark coming off the plug. It still won't turn over however. I am assuming that the cylinder is not getting enough any gas since I have tried a ton and still have a dry plug.

The bike has a dellorto carb. Gas is getting to the banjo, but I am not sure where to go from here. It was leaking out of where the exhaust meets the cylinder, but I tightened that up and no more leaking, but still no running. I have also played around with the idle screw and nothing as well has put a new throttle assembly and cable on. What other things can I check?

Re: Tomos A3 has spark, won't turn over

Kenny George /

I took the carb apart and investigated and have more information.

The throttle is working fine. The float bowl had gas in it. Seems as thought the problem is the main jet. Any suggestions on how to clean/service it. I ran carb cleaner through it, and am going to assemble it and try again, but am open to suggestions.

Re: Tomos A3 has spark, won't turn over

jeezum crowza. i'm ok with people asking silly questions because hey, you're new, everyone starts somewhere. but cleaning a carb is one of the most basic things ever, that's like asking how do i change a spark plug. There's even a bunch of youtube videos on it.

seriously.

to make it even easier i'll lay it out in excruciating detail. go buy carb cleaner. squirt it into the jet.

also - as general reference read fred's guide. http://www.mopedarmy.com/wiki/Fred's_Guide

Re: Tomos A3 has spark, won't turn over

Kenny George /

No, that's been done numerous times. All jets are clear, float is floating. Now I am suspicious of vacuum leak. Guess I should have mentioned that in my original post.

Re: Tomos A3 has spark, won't turn over

SHAs tend to leak where they clamp on to the intake.

did you reach this "vacuum leak" conclusion by following Fred's Guide?

Re: Tomos A3 has spark, won't turn over

Timing could be off, what is your compression reading... when was the last time this Tomos ran?

I once had an A3 that wouldn't run for the life of me until I did a compression test and found that whoever had it before me had shatter rings.

Re: Tomos A3 has spark, won't turn over

Kenny George /

I just hooked it to a compression tester. It is reading between 105-110psi. I'm not sure what is recommended, but it should at least run poorly with that much compression. I am new at this so willing to take advice. If this sounds normal, then I think I should not go taking the cylinder apart as to not create another problem. Thanks!

Re: Tomos A3 has spark, won't turn over

Your timing could be off possibly, but I don't suspect that. Are you getting a strong blue spark?

Re: Tomos A3 has spark, won't turn over

try spraying starting fluid around the cylinder and if the engine revs up or fires up, you know there is a air leak. Or spray it directly into the cylinder and see if it runs, then you will know that it isn't getting gas.

Re: Tomos A3 has spark, won't turn over

Did you ever resolve this? I'm having troubles myself and am curious to see if you reached a resolution.

Re: Tomos A3 has spark, won't turn over

Take the spark plug out and put a little gas in the cylinder, then try and start it....if it runs for a second or two....you have a gas problem. Its that simple.

The most common problem is a dirty jet in the carb....I use a very small wire and purple cleaner and my tomos ran like a dream...I know the instructions said no wire....but wire was the only way it cleaned up the stopped up hole.

Also try and give it gas when trying to start it....may be a cable adjustment problem causing it not to start.

I just sold an A3 Bullet TT, and it would run for a few minutes, then just die. It turned out that I had to drill holes in the frame at the air box right before the air cleaner to get this bike runnning.

It helped the transmission shift faster, smoother and the bike run twice as fast....I think the air box never had a hole to intake air or too small...it took me quite a few hours and days to discover the problem.

Re: Tomos A3 has spark, won't turn over

Kenny George /

I've been out of the country so haven't had time to address the problem, but last time I left it, I had spark, gas, compression, but couldn't get it to run. Carb was perfectly clean, used a compression tester and it was around 120psi, and was getting a blue spark. I even tried putting some gas directly in the cylinder to see it I could get it to fire for a second or two, but that didn't work.

I am completely stumped at this point and will probably have to call in an expert. Maybe a timing issue or the spark may not be strong enough, or an air intake problem, but I would suspect that with any of these three problems I could at least get the bike to start and run poorly or start and die immediately.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account