broke my rings

I have a 1978 concord with a minerelli. well I was getting a knock in my motor and my plug tips were getting bent over a hair, I took my head and cylinder off all looked good except my rings were missing a 1/8 inch of the ring itself, I thought this was the way they were supposed to be but when I put the cylinder on, or well started to, I held the rings closed,since there was a gap on them, but they both broke. I am broke with a new baby, and I use this to get to work so my wife can drive our car, were these rings suppose to have a peace missing? and were can I get a cheap set, I mean cheap, I pawned my other moped and this is my only moped left. thanks, I love to keep my knees in the breeze.

sad mopeder.

Re: broke my rings

I'll PayPal you 5 bucks. Give me the address. Happy fathers Day. It's a start.

Re: broke my rings

for real Mikey, that's whats cool about fellow mopeders. How much do rings cost? I haven't even looked yet. johnson.jack76@yahoo.com

What can I say, thanks sounds empty, but I will pass on the good karma, I am a helper by nature. I have a 5 year old son, and a 2 week old baby girl, my wife is on FMLA and thats why we are short right now, normally it wouldn't be so hard to buy repair parts, Thats part of moped owner ship.

thanks again.

Re: broke my rings

http://www.1977mopeds.com/product/747 they are $15 at 1977 and out of stock at treats. I didn't check anything else. PayPal should be at you in a minute or 2.

Re: broke my rings

I sent 8 because life is easier when you are more than 1/2 way to a goal. Get you some rings.

Re: broke my rings

there is nothing I can say that expresses how appreciative I am of your kindness to a complete stranger. ride on man.

Re: broke my rings

Jimbo Grand Daddy /

When you get the rings, make sure to check for proper end gap. And when you install the cylinder, make sure you align the gap with the locating pins in the ring grooves. Wish I could help on the finance end.

Re: broke my rings

thanks for the advice on how to install, mine crumbled apart when I squeezed them the slightest amount, I have to beleave they were old and rotten, plus I was getting a lot of chatter from the cylinder when running. everything else is good or seemes to be. solid and responds well when I push or pull the piston and rod. ride on jimbo

Re: broke my rings

Maybe they were on the locating pin and your leverage snapped it.

Pins are on intake side of piston, and arrow points to exhaust.

Re: broke my rings

sounds plausible, I have dealt with rings some but never had them brake like this. but I wasn't going as slow as I should have. andything else I should be aware of or do. my studs are good, I cleaned my piston, cylinder and head with carb cleaner and then wiped them down with oil, put a bag over piston and tarp over bike outside tonight.

Re: broke my rings

I'm not sure how you're doing it, but from your last post I think you have the piston still attached to the engine. I have found it a lot easier to remove the piston to get it into the cylinder, then lower the assembly onto the studs and install the wrist pin. Fumbling with the cylinder and rings while trying to get everything together with the piston still on the rod is a real pain and can easily lead to more broken rings. However, if you find that the wrist pin is really difficult to remove, this might not be the way to go.

Re: broke my rings

Well I got my rings from 77mopeds today, and installed. ran ok, slowed my timing and that seemed to help. still wants to stall some when idling. thats not horrible for now. thanks for the tips and greenmikey for the $8.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account