E50 3-shoe clutch randomly not dis-engaging

Luke “Funkenet” Hosfield /

So like once out of 20-30 times that I come to a stop my clutch isn't disengaging. It can go all the way to a dead stop without the clutch letting go of the bell.

Obviously it won't idle like that so it stalls. An easy way to fix it is to roll the back tire back and forth and it will come loose.

What would cause this?

Re: E50 3-shoe clutch randomly not dis-engaging

Salsa Salsa /

Bent posts

Re: E50 3-shoe clutch randomly not dis-engaging

Luke “Funkenet” Hosfield /

Why does it happen only rarely then?

Re: E50 3-shoe clutch randomly not dis-engaging

Probably Fred /

Or starter clutch problem/ too tight adjusted

Re: E50 3-shoe clutch randomly not dis-engaging

Luke “Funkenet” Hosfield /

I doubt it but its worth checking anyway.

Re: E50 3-shoe clutch randomly not dis-engaging

Probably Fred /

I had a starter clutch plate bad bearing that caused same kind of problems cause then I over tightened the clutch. The spec is at the lever min 1/2 inch play

Re: E50 3-shoe clutch randomly not dis-engaging

I had one where the spring holes in the center section were drilled crooked, causing the spring to hang up sometimes. Check your holes and either dremel them straight or get a new clutch base.

Re: E50 3-shoe clutch randomly not dis-engaging

Luke “Funkenet” Hosfield /

Hadn't though of that jake. New clutch base is coming they're so cheap I should've got two.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account