Jawa ignition coil problem...

Colton Opinker /

I tested all of my coils with a multimeter and the only one that did not give me a beep was the ignition coil...I have 2 of them and they both did not give me readings... The rest of the coils did however, im assuming i need to get new ignition coil for my engines then? I have the black box but I am converting it to the home made thrysistor. anybody got a couple spare working ignition coils or is that not the problem?

Re: Jawa ignition coil problem...

Patrick Keaton /

I would wait to the homemade thrysistor has been converted before doing anything. The thrysistor can even produce a spark at the spark plug, but not be strong enough to start the engine.

Re: Jawa ignition coil problem...

bet your coils work

usually its the thyster that gives trouble

there are test parameters at jawamoped.com

and how to test Jawa ignition systems

Re: Jawa ignition coil problem...

Colton Opinker /

Instead of testing (or replacing for that matter) a unit that is naturally faulty with a used unit of the same quality I just decided to shelf the old faulty tranzimo and the thrysistor unit with the homemade unit. question is, are the homemade units considered wear units as well?

Re: Jawa ignition coil problem...

check the continuity through that ignition coil, the wiring is very fine and breaks/ gets cut very easily. mine broke right near the solder post, but it was very hard to see as the wire is like a hair. I just unwraped 2 turns to give me some length and soldered it back on,and viola!

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account