Puch not running right...

So my puch had a crack in the stock 12carb so i upgraded it with a new 15mm bing but once i got it on it wont run right. It starts and when i start to move it takes a long time to get going over 15. It seems like i cant go full throttle until i hit 20ish and it then picks up to 27 or so. I have to keep the throttle half way until the engine revs up to how it should sound then it runs fine... or until i get to a hill or or have to stop. I had it going just fine before the carb broke. I cant figure out what wis wrong. The low end should not be this bad. Any ideas?

Puch Newport stock E50 with a Boss pipe and a 15mm Bing Carb clone with a 72jet in it, and a lightened clutch and a 12mm intake.

Re: Puch not running right...

a 12mm intake... first problem

a lighted clutch? why?

Re: Puch not running right...

72 might be a little high for an otherwise stock setup. Have you tried other jet sizes?

Also, yeah, the clutch. Lightening it can help, but was it lightened before you swapped the carb, or did you do that at the same time? (Just trying to figure out if it the clutch worked properly before you swapped the carb).

Re: Puch not running right...

The clutch was stock when i first got it and was working fine. When i swapped the carb the low end was just shit so i tried putting on a lightened clutch to see if that could help because ive tried everything. So ive tried both the stock clutch and the lightened.

As for the jets ive tried a 58,72,74,82. The 72 worked the best.

Re: Puch not running right...

Hmmm....

What about like, a 66? 58 to 72 is kind of a big jump. I have a Puch that had a case leak, and it was jetted at a 78. After I rebuilt it, I tried it with the 78, and it could barely propel itself forward, kind of like you're describing. I kept downjetting till I got to a 68 or 70, and then it worked properly again. Even one jet size can make a big difference.

You may also want to check your float height. I'm working on a Magnum now that also runs a lot like you're describing. It's got a brand new 15mm Bing on it, but for some reason, if we replace that carb with the carb off my Swinger (clone Bing), it runs about a million times better, even with the same jet. Some of that might be float height, it might be the atomizer ... we aren't sure yet. But it might be worth the time to swap out some of those parts, or try different needle settings.

Re: Puch not running right...

Overpriced Parts /

Atomizer should be a 217# on a 15 mm bing

# 222 for a 14 mm bing

Clone atomizers are neither .

I had a clone 15mm and I was lucky it ran good with the jet and the atomizer that was in it.

Putting a 15 mm carb on a bike that has a stock exhaust/and maybe airbox on it will make you sad.

A stock carb is the best for a stock set up

Re: Puch not running right...

Ill try to change the atomizer with my old carb that has a cracked body. I have a pipe on it so its not a fully stock bike. Ill have to order some more jets to see if that works.

Re: Puch not running right...

Overpriced Parts /

Not a good idea a 12mm atomizer will be too rich for a 15 mm carb

Re: Puch not running right...

so if not the atomizer what do you think could be causing it to run like that?

Re: Puch not running right...

Overpriced Parts /

Jetting problem

Re: Puch not running right...

i ordered 64, 66, 68, 70 jets. ill have to see if those will fix the problem.

Re: Puch not running right...

Overpriced Parts /

You need a 15 mm intake, a true bing 217 atomizer, and a jet range #76-80

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account