Jawa 210 Clutch Disengaging Issues

Nick Nothom /

Hey Guys,

I got my Jawa 210 back up and running a few days ago, it was out of commission due to ignition issues. I'm noticing now that it doesn't idle smoothly when stopped on the road, and you need to keep feathering the throttle. Also, it tends to stall if you brake quickly.

Another thing to note is that when it's idling on the center stand, it'll do okay for a few seconds, but as soon as the rear wheel starts spinning a little bit, it seems to fully engage, it spins the rear wheel up to like 30MPH. So as soon as as the clutch engages it tends to rev up rather high, and that causes the wheel spinning.

Sounds like a transmission/clutch issue to me, like something isn't letting go.

What do you think?

~thanks~

Re: Jawa 210 Clutch Disengaging Issues

Nick Nothom /

Another thing to note is that I have the Jawa "130" which was the economy model of the 210, with a 1 speed transmission. That should be the only difference. I can't find any info on the 130, when you google it, there are basically no results which pertain to the bike.

Re: Jawa 210 Clutch Disengaging Issues

John Warren IhazJawas /

had the same problem play with you mix\idle screws mine works brety good at 1 and 1\2 turns for the right screw and about 3 turns for left screw but you may need to play with it to find where it works best for you

Re: Jawa 210 Clutch Disengaging Issues

you may need to pull the clutch hub and check your

clutch shoes

you might have a broken spring

what was your ignition problem?

if your bike sat for awhile did you clean the

fuel system out

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account