PA50 started and than pooped out

Sara Danker /

So i got a 81 Hobbit PA50II today. Stared up just fine when I bought it. Got it home rode it around a little and than it pooped out. My boyfriend than realized he hadn't turned the fuel to on and it was on off. It now wont start at all. Started once and died out shortly after with it in reserve but when the fuel switch is on, no dice. There is gas in it... Lights are working and it sounds like it wants to start but just doesn't get going. Any ideas?

first moped and first post :)

Re: PA50 started and than pooped out

Downhill Harvey (OFMC) /

Re: PA50 started and than pooped out

Are you using the choke?

Re: PA50 started and than pooped out

Sara Danker /

tried it both ways and nothing

Re: PA50 started and than pooped out

make sure you are getting fuel thru the petcock and fuel line. If it was sitting for a long time before u got it you may also have some junk in the tank that made its way into the carb. these carbs must be very clean to function properly. check the wiki for how to clean it. clean it twice ...atleast.

Re: PA50 started and than pooped out

^Yes, but after you do, clean the tank, and the little filter in the petcock. If you don't this will keep happening. My Hobbit NEEDS the choke to start easily even after sitting briefly. Warms right up though. If you use your decomp, could it have stuck open? (I have never used mine ever).

Re: PA50 started and than pooped out

sounds like its toasted, i will take it off your hands. jk probably a carb issue those stock carbs can be a pain in the ass. check out the wiki it will walk you through it. if it sounds like to much work let me know i would be interesed in buying your hobbit. good luck

Re: PA50 started and than pooped out

clean clean clean the carb and the rest of the fuel system

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account