Don't know what to do..

Alex Sturtevant /

Just finished a complete rebuild / restoration of a 1980 Puch maxi. The engine runs but it won't idle and will only run if it's at wot. The engine dies if you let go of the throttle as well and the engine provides no power to the wheels. Already looked on the forum with no luck.. It's all stock except it has a hi-flow airfilter. The brake/tail lights are not working / not wired right now. The bike ran fine two days ago, after rewiring it did not run. We wired it back to what we had it at before but still no luck. We checked spark, gas, cleaned the carb, and tuned the carb. still nothing. It's jetted at 70 for the hi flow air filter. any ideas? Checked exhaust w/o pipe it ran idled and reved up well seemed to have power. Changed to another clean pipe and it went back to not idling or having power.

Re: Don't know what to do..

Luke “Funkenet” Hosfield /

Sounds like a big ol airleak to me.

Re: Don't know what to do..

Probably Fred /

What size carb ?

If 12 mm 70 is too big

Re: Don't know what to do..

Luke “Funkenet” Hosfield /

Oh ya. 70 is big.

Re: Don't know what to do..

Patrick Keaton /

64 is the biggest to go stock, but if you have performance pipe and high flow air filter, it is not that high, but could be high enough to cause you problems. If you got a 15 carb, that might be a little small for your set up. Start installing all the stock parts you have back on there, and then put on the perfomance parts after you see how it reacts with stock parts.

Re: Don't know what to do..

Alex Sturtevant /

Just went back to stock jet and stock air filter still having the same problem

Re: Don't know what to do..

♣Slew Foot♣ /

safety on the horn, tail brake all working and propperly fuctioning with the right bulbs?

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account