My ped will idle, but kills when I give it gas

I have a 1980 Vespa 49cc. It idles great, but as soo as I give it throttle it dies. It sounds like it is flooding. I can feather the gas and get it to accelerate on the stand, but can't get anything when the tires are on the ground.

I cleaned the carb, put in a new spark plug, and the air filter is off. There is no mixture adjustment screw on the carb. Anyone have any ideas?? Any help is appreciated.

Re: My ped will idle, but kills when I give it gas

sounds like your jets are improper. maybe needs an upjet, lean bog kinds sounds like flooding. sputter means too rich. those things need the air filter, or a bigger jet. might also be you've got poor compression

Re: My ped will idle, but kills when I give it gas

♣Slew Foot♣ /

i would check all the fuel line filters and the petcock sounds as though you are not getting fuel, or gas cap vent. if you choke it and it gets better then its your fuel system.

Re: My ped will idle, but kills when I give it gas

norwegian bastard /

did this happen after cleaning the carb? if so you probably cleaned it but then something small clogged up something again. not to hard to have happen. take the carb off and re clean it spic and span. clean out the jet with something fine like a small strand of wire. re-install AND MAKE SURE there's no air leaks on the carb manifold or anywhere else.

Re: My ped will idle, but kills when I give it gas

Dude, my tomos had an air leak that would act like this. Run "just fine" until I had to stop. Then when I would take off it would want to die. Check for air leaks first and then check for proper carb jetting.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account