Garelli ran perfectly with new clutch... Now won't start

I have a '78 Garelli Eureka and my friend just put in a fresh clutch. It ran perfectly and took me all the way home. Now it won't fire! Please help? I'm competent with learning but don't know much about why things go wrong.

Re: Garelli ran perfectly with new clutch... Now won't start

Roger Vigliotti /

Could it have something to do with my gearbox oil/possible lack thereof?

Re: Garelli ran perfectly with new clutch... Now won't start

Kenneth Sanders I I /

could be, hopefully he put in 30Non Detergant oil in there.

Re: Garelli ran perfectly with new clutch... Now won't start

same thing happened to me when I got mine, well not exactly, made it about a mile and a half and it was done. For me it turned out to be a cracked cylinder head, which I didn't figure out until I did a compression test. (I had 30 psi.) Fred's guide in the wiki has some really good info. Try and figure out which element is causing problems and i'm sure someone can help you out.

Re: Garelli ran perfectly with new clutch... Now won't start

***VANILLA BLUNDER*** /

did you not put oil in it? in the transmission that is (edited)

Re: Garelli ran perfectly with new clutch... Now won't start

?? maybe it just flooded?

I had a leaky carb one time that would flood my engine everytime i turned it off unless i killed the fuel line early..

Re: Garelli ran perfectly with new clutch... Now won't start

Roger Vigliotti /

Thank you all for the help and advice. I think what I'm going to do is why I should've done from the start... Take it all apart ad clean everything, replace what isn't pristine and put it all back together. I really should get to know Lucy a little better.. She's blue ad from 1972, just so everyone knows. It could open me up to buying a not-so-project moped anyway. Thanks again for the help and insight!

Re: Garelli ran perfectly with new clutch... Now won't start

Before you start tearing it apart try and isolate the problem. Check spark, compression, fuel. Just my opinion, but if you accidently fudge something up while cleaning you may have multiple issues to pin point instead of one. Good luck!

Re: Garelli ran perfectly with new clutch... Now won't start

Thumbs up to that

Re: Garelli ran perfectly with new clutch... Now won't start

Please check you 3 basics as posted. Also remember, you need non detergent oil. If you put regular oil in it, then your rubber clutch thing (name?) is probably swollen as fuck by now.

Re: Garelli ran perfectly with new clutch... Now won't start

Roger Vigliotti /

Swollen as fuck.. Probably the case my man. It seem like it just seizes in the clutch. Where do I get new non detergent oil?

Re: Garelli ran perfectly with new clutch... Now won't start

NAPA

Re: Garelli ran perfectly with new clutch... Now won't start

Roger Vigliotti /

I went to pep boys and I don't think any of their 30weight was non detergent. They all said they clean and rejuvenate and preserve. How do I tell if it's non detergent? And is it motor oil I'm looking for?

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account