Puch won't spark! Need Help

I have replaced the condensor and coil on my '77 Puch Maxi and with brand new parts. When I peddle, the headlight glows slightly, but it doesn't spark. What the hey is the problem? I'm almost going nuts. Is it electrical? the points? It only has 4k miles on it.

Re: Puch won't spark! Need Help

P.S. I cleaned the carb and the air filter is stock. I also cleaned the tank and got a new fuel filter/petcock.

Re: Puch won't spark! Need Help

clean the new points. sometimes a flim on the points when new.

Re: Puch won't spark! Need Help

and make sure there gap is set right

Re: Puch won't spark! Need Help

The points aren't new, just the coil and condensor. I set the gap at .4mm and cleaned them. I'm fearful that it's the wiring, but they're not loose or anything.

Re: Puch won't spark! Need Help

See Ya Moped Army /

Make sure both horn wires are connected to the horn.

Re: Puch won't spark! Need Help

WHich side is the negative? I just replaced the horn today. If anyone has a wiring schematic, that would be great.

Re: Puch won't spark! Need Help

Could there be something wrong with the stator plate? How could I test it?

Re: Puch won't spark! Need Help

easy trigger.http://www.mopedriders.org/html/manuals/puch/sm/puchsm.htm. look up the wiring diagram in the index. moped riders has manuals for tons of peds. take your time and make sure the wiring is all legit. sometimes you replace the wrong wire to a different spot. also, id reccomend you get a muti-meter and test your wires to see if theyre giving you current. also, that plastic thing where all your wires go in and out of, make sure all the ports work. mine had some that were dead. pat from hells satans showed me a way to wire a puch up real simply, and i dont have to mess with all the wires goin everywhere.

greger, gb

Re: Puch won't spark! Need Help

Gregor,

Do you have a picture of the wiring that pat showed you? I'm gonna look over that diagram, but I might make a mistake. THanks for your help.

Sam

Re: Puch won't spark! Need Help

🇮🇹💦 Of the Loin /

actually make sure your horn is UNPLUGGED.

just take the two wires and twist em together and get that pesky horn out of the circuit. alot of times thats the problem on puchs

Re: Puch won't spark! Need Help

THAT'S IT! I UNPLUGGED THE HORN AND TIED THE WIRES TOGETHER AND IT WORKS! THANK YOU! I'VE BEEN WORKING ON THIS MOPED FOR TWO YEARS AND I HADN'T SOLVED THAT PROBLEM UNTIL NOW AT 1 AM. I WILL THOROUGHLY ENJOY THE REST OF THE SUMMER!

Re: Puch won't spark! Need Help

🇮🇹💦 Of the Loin /

haha no problem

Re: Puch won't spark! Need Help

Bravo !!!! very good !! thats gotta feel grand Huh?

Re: Puch won't spark! Need Help

Yeah, but is there a secret gap measurement that will provide optimum timing? It used to top out at 28 or so, but now it only reaches 23 to 25. I'm getting nitpicky, but I was just wondering.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account